Dropbox config with rclone

What is the problem you are having with rclone?

I use dropbox with rclone.
For now i migrating with some gbit fiber, from google drive, to dropbox, and i maked in dropbox application, different application for every gbit transfer, to avoid any API issue.
So I created in dropbox website, an Application with App Key and App Secret for migration 1, same for migration 2 etc, in crypt.

My Issue is:

I use also another Application, in dropbox website, with App Key and App Secret, to mount dropbox in Windows 11, and I see that is too slowly, when I migrating from these gbit ( gdrive to dropbox ).
So seems that there is a limit in dropbox, also If I create different Application ?
So the limit is for the entire drive, and not for the Application?

My doubt is I use appkey and also app secret for every remote in rclone, but i can't use the token, because I have this error, when i tried to mount it:

Failed to create file system for "DROPBOX_MOUNT_W11_CRYPT_TEST_CRYPT:/": failed to make remote "DROPBOX_MOUNT_W11_CRYPT_TEST:/ROB_MASTER" to wrap: get current account failed: Error in call to API function "users/get_current_account": This API function operates on a single Dropbox account, but the OAuth 2 access token you provided is for an entire Dropbox Business team. Since your API app key has team member file access permissions, you can operate on a team member's Dropbox by providing the "Dropbox-API-Select-User" HTTP header or "select_user" URL parameter to specify the exact user https://www.dropbox.com/developers/documentation/http/teams.

Of course, without config token, works, but i don't understand why with another Application, the mount is slow.

I uploading from 2, 3 gbit server Gdrive to dropbox , with 8 parallel transfer per gbit, so are a lot of transfer in the same time and a lot of MB/s about transfer.

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: Microsoft Windows 11 Pro 22H2 (64 bit)
  • os/kernel: 10.0.22621.1702 Build 22621.1702.1702 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount DROPBOX_MOUNT_W11_CRYPT_TEST_CRYPT:/ N: --vfs-cache-mode full --tpslimit 12 --vfs-cache-max-size=1G --cache-dir=R: --verbose --allow-other --progress -vv --buffer-size 16M --drive-chunk-size 256M --vfs-read-chunk-size 256M --vfs-read-chunk-size-limit=256M --use-mmap --fast-list --volname DROPBOX_MOUNT_W11 --network-mode

The rclone config contents with secrets removed.

type = dropbox
client_id = xxx
client_secret = xxx
token = {"access_token":"bbtZjHJFbo","token_type":"bearer","expiry":"0001-01-01T00:00:00Z"}
chunk_size = 128Mi

type = crypt
password = GNBeR8
password2 = _1vrdpA
server_side_across_configs = true
no_data_encryption = true```

Nobody knows 100%. Dropbox does not make it public what their limits are.

just make it simple and do not use options which are for e.g. google drive or are not supported on windows - when you try to use random options results can be not what you want - RTFM

Here good dropbox example homescripts/systemd/rclone-tv.service at master · animosity22/homescripts · GitHub

you can start with:

rclone mount DROPBOX_MOUNT_W11_CRYPT_TEST_CRYPT:/ N: --vfs-cache-mode full --tpslimit 12 --vfs-cache-max-size=1G --cache-dir=R: --volname DROPBOX_MOUNT_W11 --network-mode --progress -vv 

What is the reason you use crypt? only to make it look cool? As you set no_data_encryption = true effectively turning encryption off.

For Dropbox crypt here is my suggestion:

type = crypt
password = *********
password2 = *********
filename-encryption = standard
filename-encoding = base32768

Do no put server_side_across_configs = true here if you are not sure what you are doing. Might be not what you want. You can always use it when needed in rclone commands.

Secondly - as it is common mistake IMHO double check that your token is bound to your client_id/client_secret and not to the default rclone one used by who knows how many people. It happens when people create dropbox remote and only later add client_id/client_secret

You could do this by running rclone reconnect DROPBOX_MOUNT_W11_CRYPT_TEST: but I recommend you delete this remote and create again - the reason being that you just made your client_id/client_secret publicly available:

so anybody in the world can use it (you should redact it the same way you did with toten). So create new appID in Dropbox and create remote again.

Now it is very important you enter client_id/client_secret during remote creation - if you do this later it does not work and you are using default rclone appID. You will see if all is fine in dropbox authentication screen in your browser.

If you see rclone logo/name - it means you are not using your appID

when you see your app name - all good - here example with my appID:

And lastly:

Follow exact steps as per manual to create new AppID:

Thanks, seems that works, but the difference, is that in the past, i flag all permission, now, only these permission, like in dropbox doc:

account_info.read , files.metadata.write , files.content.write , files.content.read , sharing.write . The files.metadata.read and sharing.read

Maybe is this the issue?

No idea - but it is the best approach just to use defaults and follow docs if you are not sure. Only when this works you can start adapting stuff to your specific requirements.

I don't understand but I have a folder with 12.208 files .mkv, and is too too too slow with rclone, list files.

Why? I don't understand how to fix it. With google drive is fast.

rclone mount DROPBOX_MOUNT_WINDOWS11_CRYPT:/ N: --vfs-cache-mode full --tpslimit 12 --vfs-cache-max-size=1G --cache-dir=R: --fast-list --verbose --volname DROPBOX_MOUNT_W11 --network-mode --progress -vv

Well... some cloud providers are faster than others...

remove --fast-list - not supported by dropbox - docs

What you can do is to warm cache before using this mount:


--rc --rc-addr --rc-no-auth

to your mount command.

rclone mount DROPBOX_MOUNT_WINDOWS11_CRYPT:/ N: --vfs-cache-mode full --tpslimit 12 --vfs-cache-max-size=1G --cache-dir=R: --rc --rc-addr --rc-no-auth --verbose --volname DROPBOX_MOUNT_W11 --network-mode --progress -vv

Mount remote - then from another terminal window run:

rclone rc vfs/refresh recursive=true --rc-addr _async=true

Have a break:) After some time your mount will be super fast.

Also add to your mount command:

--dir-cache-time 9999h 
--vfs-cache-max-age 9999h

so your cache does not to refresh all the time

Another thing you can improve is to increase --vfs-cache-max-size=1G - you use this mount for films - these are big files.

Here you can have a look at good dropbox mount for films:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.