Dropbox Business not accepting oauth2

the email is mine, the dropbox admin.
I tried without the /

rclone --dropbox-impersonate rxxxxxxx@xxxxxxx.com lsd dpbx:
2021/04/09 17:15:12 Failed to create file system for "dpbx:": invalid dropbox team member: "rxxxxxxx@xxxxxxx.com": missing_scope/..

try adding -vv to see if you get more error details. It does look as the email is not correct.

When I read the man it would seem I have to use the --dropbox-impersonate for the rclone config?

--dropbox-impersonate

Impersonate this user when using a business account.

Note that if you want to use impersonate, you should make sure this flag is set when running "rclone config" as this will cause rclone to request the "members.read" scope which it won't normally. This is needed to lookup a members email address into the internal ID that dropbox uses in the API.

Using the "members.read" scope will require a Dropbox Team Admin to approve during the OAuth flow.

You will have to use your own App (setting your own client_id and client_secret) to use this option as currently rclone's default set of permissions doesn't include "members.read". This can be added once v1.55 or later is in use everywhere.

  • Config: impersonate
  • Env Var: RCLONE_DROPBOX_IMPERSONATE
  • Type: string
  • Default: ""

I will give it a go....

1 Like

could be, been a while since I did that step actually. I mostly use user-scoped apps.

here is the -vv:

rclone -vv --dropbox-impersonate rxxxxxxxxx@xxxxxx.xxxxx lsd dpbx:/
2021/04/09 17:19:09 DEBUG : Using config file from "/home/pi/.config/rclone/rclone.conf"
2021/04/09 17:19:09 DEBUG : rclone: Version "v1.55.0" starting with parameters ["rclone" "-vv" "--dropbox-impersonate" "xxxxxxxxx@xxxxx.xxx" "lsd" "dpbx:/"]
2021/04/09 17:19:09 DEBUG : Creating backend with remote "dpbx:/"
2021/04/09 17:19:09 DEBUG : dpbx: detected overridden config - adding "{0svDK}" suffix to name
2021/04/09 17:19:09 Failed to create file system for "dpbx:/": invalid dropbox team member: "xxxxxx@xxxxxx": missing_scope/...

fyi: actually it is for a backup - just read only- to backup all the Teams folders...

that is a known issue here at the forum, so search the forum for it.
i think there is a beta or some kind of work around.

Thanks. Yes. The link to the thread:
Dropbox - no “members.read”

apparently unresolved.... yet. I will give it a deeper look later tonight.

This should be fixed with rclone 1.55 - dropbox changed their oauth scopes recently...

See: Dropbox for more info.

Thanx. Apparently there is a fork with a fix.
I use the standard 1.55 and the issue is still there.
rclone version
rclone v1.55.0

  • os/type: linux
  • os/arch: arm
  • go/version: go1.16.2
  • go/linking: static
  • go/tags: cmount

So I test the fork :frowning:
rclone-v1.55.0-beta.5175.aee3bfb17.fix-dropbox-scopes-linux-arm64.deb
from Feb 2021.
I will report after testing.

Well so far not much luck even with the forked version:
$ rclone version
rclone v1.55.0-beta.5175.aee3bfb17.fix-dropbox-scopes

  • os/arch: linux/arm
  • go version: go1.16rc1

I access my personal folder but not the Teams shared folder....
still the same error all the time:
$ rclone lsd dpbx:/
2021/04/09 22:16:30 Failed to create file system for "dpbx:/": get current account failed: missing_scope/.

and

$ rclone --dropbox-impersonate rxxxxxxxxxxxx lsd dpbx:/
2021/04/09 22:17:16 Failed to create file system for "dpbx:/": invalid dropbox team member: "xxxxxxxxxxxxx": missing_scope/.

sadly...... :frowning:

I'm pretty sure those changes got merged into v1.55 dropbox: add scopes to oauth request and optionally "members.read" · rclone/rclone@37e6301 · GitHub

Can you run this please with v1.55?

rclone config --dropbox-impersonate "xxx" reconnect dpbx:`

That should get you the extra scope.

I have tried all possible ways..... from here and from

https://forum.rclone.org/t/dropbox-no-members-read

Saddly, rclone is no longer working with Dropbox business. So bad...
And the issue is clearly coming from Dropbox themselves.
Shame on them...
:frowning:
Finally I have use Multcloud and setup an FTP on my NAS-Rpi . Multcloud does work very well with DropBox business Teams folders. So I use Multcloud for accessing Dropbox business and then backup all my Team folders to my NAS-Rpi via SFTP (SHH ftp actually). I did not want to do that as I have now to watch and protect some ports on my Rpi-NAS and on my router... but this is life...

For what its worth, I managed to set a new team app up today, there seems to be a bug (at least with some rclone versions) not requesting the proper scope, but I managed to manually add the scope to the URL when authorizing the App with your Dropbox business team.
And then it works fine for me.
I ran the config with the --dropbox-impersonate flag (and a team admin email ) and in the generated URL that gave the error about missing scope I manually in the URL inserted "manually add "+team_data.member" and then I could authorize the app and get it to work.
EDIT: also confirmed this bug (and successful workaround) on below build:
rclone v1.55.0

  • os/type: windows
  • os/arch: amd64
  • go/version: go1.16.2
  • go/linking: dynamic
  • go/tags: cmount

That is really useful info thanks.

I've tried to fix this here - can you try rclone config reconnect with an impersonate email address and see if gives you the right scopes?

If it does I'll merge this for 1.55.1

v1.56.0-beta.5409.9b054c0cd.fix-dropbox-impersonate-scopes on branch fix-dropbox-impersonate-scopes (uploaded in 15-30 mins)

Yes, this build correctly requests the team_data.member scope in the generated URL, which makes the error go away.
With this I could successfully setup a new Dropbox remote with rclone towards a team-centric Dropbox app.

1 Like

Hi Guys,
I confirm it does work with v1.55.1 does it.
Many thanks that does help!
Best,
Robert

2 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.