"drive-skip-gdocs" being ignored

What is the problem you are having with rclone?

I am "check"ing and "sync"ing a local folder to google drive, but --drive-skip-gdocs is not being respected (note: this used to work before). When I do a check I get:

2022/05/13 15:24:16 ERROR : TEST: File not in Local file system at /gdrive/scratch

Where TEST is the name of an (online) google doc. If I sync the two with:

rclone sync ./scratch gdrive:/scratch --drive-skip-gdocs

The TEST document gets deleted/removed from the scratch remote directory.

Run the command 'rclone version' and share the full output of the command.

rclone v1.50.2
- os/arch: linux/amd64
- go version: go1.13.6

(I am on Ubuntu 20.04 LTS, using rclone installed via apt)

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

~/gdrive$ rclone check ./scratch gdrive:/scratch --drive-skip-gdocs
2022/05/13 15:34:28 ERROR : TEST DOC: File not in Local file system at /home/xx/gdrive/scratch
2022/05/13 15:34:28 ERROR : TEST SHEET: File not in Local file system at /home/xx/gdrive/scratch
2022/05/13 15:34:28 NOTICE: Local file system at /home/xx/gdrive/scratch: 2 files missing
2022/05/13 15:34:28 NOTICE: Google drive root 'scratch': 2 differences found
2022/05/13 15:34:28 NOTICE: Google drive root 'scratch': 1 matching files
2022/05/13 15:34:28 Failed to check with 3 errors: last error was: 2 differences found

Where TEST DOC and TEST SHEET are online google documents only. I was expecting these to be ignored.

The rclone config contents with secrets removed.

[gdrive]
type = drive
client_id = 
client_secret = 
scope = drive
token = {"access_token":"","token_type":"Bearer","refresh_token":"","expiry":"2022-05-13T16:33:40.617267506+02:00"}
root_folder_id = 

Nothing special here.

A log from the command with the -vv flag

2022/05/13 15:39:44 DEBUG : rclone: Version "v1.50.2" starting with parameters ["rclone" "check" "./scratch" "gdrive-um:/scratch" "--drive-skip-gdocs" "-vv"]
2022/05/13 15:39:44 DEBUG : Using config file from "/home/xx/.config/rclone/rclone.conf"
2022/05/13 15:39:45 INFO  : Google drive root 'scratch': Waiting for checks to finish
2022/05/13 15:39:45 ERROR : TEST DOC: File not in Local file system at /home/xx/gdrive/scratch
2022/05/13 15:39:45 ERROR : TEST SHEET: File not in Local file system at /home/xx/gdrive/scratch
2022/05/13 15:39:45 DEBUG : Dna-icon.png: MD5 = b21d6204dcef0e4b062828133a2eb58a OK
2022/05/13 15:39:45 DEBUG : Dna-icon.png: OK
2022/05/13 15:39:45 NOTICE: Local file system at /home/xx/gdrive/scratch: 2 files missing
2022/05/13 15:39:45 NOTICE: Google drive root 'scratch': 2 differences found
2022/05/13 15:39:45 NOTICE: Google drive root 'scratch': 1 matching files
2022/05/13 15:39:45 Failed to check with 3 errors: last error was: 2 differences found

hello and welcome to the forum,

update rclone to latest stable, v1.58.1 and test again.
the only way to do that is https://rclone.org/install/#script-installation

Oh well, upgrading to the latest rclone made the problem disappear (thanks!) but this doesn't help the thousands who rely on Ubuntu's LTS apt repositories.

1 Like

Rclone doesn't maintain any repo for any distribution. You can always work with, update and/or ask the maintainer of the repo or help the maintainer of the repo to update.

The repos are community driven so generally if they aren't updated, that's something you can help fix.

well, that is true but going forward,
to update rclone, use rclone selfupdate