--drive-shared-with-me problem

--drive-shared-with-me problem doesn't comply with same folder protocol. It creates another folder with the exact same name regardless if it already exists.

How do I prevent it from creating a new folder every single time?

Edit: It happens on individual files too.

1 Like

This is a known issue

Which I haven't got round to fixing yet (mostly because I can't figure out how!)

You can work around it I think by creating a duplicate drive, one with the shared_with_me = true parameter, then when you want to copy between them copy from shared_drive to normal_drive and you won't get the duplicate. You'll need to set --drive-server-side-across-configs

Perhaps a better solution would be for --drive-shared-with-me to show all the shared files and all of you own files?

Yes i'm already using this.

For me, the workaround is to do multiple rclone copy of the various folder from shared with me folder. Can't dump the main folder directly. Need to segregate the various subfolders. ALSO, dont use any directory for the destination remote (X:).

e.g.
Shared with me = drive:maxfolder --drive-shared-with-me
To do a copy,
rclone copy drive:maxfolder/1 X:
rclone copy drive:maxfolder/2 X:
rclone copy drive:maxfolder/3 X:
rclone copy drive:maxfolder/4 X:
and so on,

Afterwhich, manually transfer folders 1-4 from X: to the intended destination. This is the only way not to have duplicates.

It would help if rclone had a flag to grab ALL files ignoring the directory. Meaning "files in folders" flag, including nested subfolers. Don't know if it exists, but would be helpful if you shed a light on that. It will be messy but I could then easiy dump rclone copy drive:maxfolder X: knowing only files are on X:

Interesting work around :slight_smile:

You are after a --flatten flag or something like that I think.

Is it on rclone? Can't find it.

I just discovered --drive-shared-with-me is essentially a pseudo public link. I could copy from other remotes unrelated to it whatsoever (different drive). This changes everything.

Not yet, no.

What do you mean?

titan@gmail.com = titan:
zeus@gmail.com = zeus:

titan: is the one that has files in shared with me.
zeus: empty shared with me

But when you copy titan: zeus: it works. Making it "pseudo" public.

1 Like