Download GD slow

hi,

  • on windows, --allow-other does nothing so you can remove it.

  • copying files via mount is slower then rclone copy or rclone browser, which uses rclone.

So here is the command you have in the log:

2020/12/20 16:47:50 DEBUG : rclone: Version "v1.53.3" starting with parameters ["C:\\rclone\\rclone.exe" "mount" "--allow-other" "--dir-cache-time" "72h" "--drive-chunk-size" "256M" "--log-file=mylogfile.txt" "--log-level" "DEBUG" "--vfs-read-chunk-size" "512M" "--vfs-read-chunk-size-limit" "off" "gdriveencrypt:" "Y:" "--config" "C:\\Users\**\\.config\\rclone\\rclone.conf" "--vfs-cache-mode" "full" "--no-checksum"]

Remove:

--allow-other
--vfs-read-chunk-size
--vfs-read-chunk-size-limit

Pick a size of how big you want your cache to be stored on disk. This must be as large as the total size of what you think you may concurrently stream as it needs to be big enough to hold all the full files.

--vfs-cache-max-age duration         Max age of objects in the cache. (default 1h0m0s)
--vfs-cache-max-size SizeSuffix      Max total size of objects in the cache. (default off)

I'd change in the age to something larger than an hour but that is really up to you.

Ok i will buy a new SSD for the cache because my biggest movie is 140Go and if i get 3 or 4 stream at the same time that will just don’t fit in my C: drive !

Thank’s for your help!

Hello ! I’m back, and not with good news.

So i added a new SSD for the cache, and got the same problem, stuck at 6.5 MB/s, i tested drive file stream by Google and same Speed ! Before my upgrade from Gsuite business to Worplace enterprise i was not restricted, I had watched very heavy 4k movies without worries.

I tested all that I could and that was achievable by myself, and no progress...

I think it’s time to rebuild my data server and only store light movie and tvshow on the drive.

Happy new year all !
Thank’s for your help !

Update : i just installed a new server and try to add rclone and nssm with the exact same settings, just for Check and... that’s working perfectly, around 100MB/s I don’t know why in Windows 10 that’s fucked but on windows server 2012R2 it’s perfect!

take a look at this post where i solved windows 10 computer slow to download from GD.

this solution has worked for several other rcloners.

Very slow speeds with Google Drive - #13 by asdffdsa

i would be curious to see the settings on the WIN10 machines as compared to WS2012R2

1 Like

Ok you solved my probleme !

netsh int tcp set global autotuninglevel=normal

And now on windows 10 pro i have 110MB/s, probably the last october update change this settings, because before that’s worked perfectly !

But thank’s you ! Probleme solved !

(When i said « exact same setings », rclone ( same id user and secret) nssm ( same command Line for mount my rclone remote)

great! glad to help solve that problem.

my experience is that windows servers are never a problem, in this way.

what was the value for autotuninglevel before you changed it to normal?

Disable to normal ! Just finish LOTR 4K :star_struck:.

Windows Server 2012 is on disable to but not probleme on this one I don’t know why

good movie, great book....

on WS2012R2, you ran plex player, played LOTR 4K, no problems?

can you post the output of
netsh interface tcp show global

Server 2016, defaults (don't recall ever messing with it):

TCP Global Parameters

Receive-Side Scaling State : enabled
Chimney Offload State : disabled
NetDMA State : disabled
Direct Cache Access (DCA) : disabled
Receive Window Auto-Tuning Level : normal
Add-On Congestion Control Provider : default
ECN Capability : enabled
RFC 1323 Timestamps : disabled
Initial RTO : 3000
Receive Segment Coalescing State : enabled
Non Sack Rtt Resiliency : disabled
Max SYN Retransmissions : 2
TCP Fast Open : disabled

WS2019-HYPERV edition

TCP Global Parameters
Receive-Side Scaling State : enabled
Receive Window Auto-Tuning Level : normal
Add-On Congestion Control Provider : default
ECN Capability : enabled
RFC 1323 Timestamps : disabled
Initial RTO : 3000
Receive Segment Coalescing State : enabled
Non Sack Rtt Resiliency : disabled
Max SYN Retransmissions : 2
Fast Open : disabled
Fast Open Fallback : enabled
HyStart : enabled
Pacing Profile : off

is that your virtual machine on the cloud?

Physical dedi, yes.

Windows 10 Enterprise 64-bit, latest:

Receive-Side Scaling State : enabled
Receive Window Auto-Tuning Level : normal
Add-On Congestion Control Provider : default
ECN Capability : disabled
RFC 1323 Timestamps : disabled
Initial RTO : 1000
Receive Segment Coalescing State : enabled
Non Sack Rtt Resiliency : disabled
Max SYN Retransmissions : 4
Fast Open : enabled
Fast Open Fallback : enabled
HyStart : enabled
Proportional Rate Reduction : enabled
Pacing Profile : off

now what?......

just goes to show that defaults are quite different between Server and regular Windows...

...but it also shows that the most important setting is the same.

what is more important than Receive Window Auto-Tuning Level

That's the one I mean, of course :slight_smile: