Does rclone still copy as much as possible without the --drive-skip-dangling-shortcuts flag?

What is the problem you are having with rclone?

This is not exactly a problem, just a question about the behaviour of rclone when faced with dangling shortcuts with google drive. I am using TrueNAS which comes with a bundled (albeit older) version of rclone (v1.56.1) which does not have the --drive-skip-dangling-shortcuts flag. I was wondering if rclone would copy everything from the remote source even without the flag. Thanks for your time and help!

Run the command 'rclone version' and share the full output of the command.

rclone v1.56.1
- os/version: debian 11.2 (64 bit)
- os/kernel: 5.10.142+truenas (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.16.8
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy remote: ./

The rclone config contents with secrets removed.

[remote]
type = drive
scope = drive
token = 
team_drive =
client_id = 
client_secret = 

A log from the command with the -vv flag (Not applicable as this is just a question)

You'd want to install / update to the latest and use the flag as you'd be riddled with errors otherwise.

I'm afraid that I am unable to, hence why I am wondering if rclone would still continue copying even if it experiences such errors.

I do understand that this is completely a limitation imposed by my setup so thank you very much for your time!

Best bet is to run your command, share a log and you can see what happens.

That's an old version so many fixes since then so guessing what some old version might do or not do doesn't help if you are trying to ensure things are proper.

Ah, not sure if I can get that from truenas - I might need to do some digging.

Alternatively, I could download and run the latest 1.60.x binary from the command line (without using the installer), would this create any issues or should this be fine in the context of rclone?

Once again, thank you so much for your help and prompt response.

I'm really not familiar with TrueNAS so I am not sure how updating would work.

If you can't generate a log, that makes tracking and validating things much harder.

"Generally", I would think it would copy fine, but without seeing it, it's tough to be sure.

If you can't see any log files, not sure how you'd know things work or didn't work so that would be a huge problem for me.

It is indeed troublesome so I am thinking of using the alternatively previously mentioned (using a standalone binary) as I am able to directly run that from within the command line (and generate logs if necessary, which I don't think I will need since I have the flag on the latest binaries)

The only question I have now would be if rclone can run straight from the binary with no issue, that is to say without using the installer as recommended.

hi,
i run into that problem now and again, just so happens yesterday with a qnap

rclone is a single file, portable executable, does not need to be installed using a script.
can manually download rclone using curl, copy it to /usr/bin` or whatever is correct for your system.
and tweak chmod/chown

not an expert at all this but works for me.

i use opnsense for routers, it uses freebsd, same as truenas core
and i can tell you that this works to update rclone

  1. to be safe, backup the current rclone something, using something like
    rclone cp /usr/bin/rclone /usr/bin/rclone.old
  2. run
    rclone selfupdate

Unfortunately, TrueNAS (I'm using SCALE so Debian-based) strongly advises not to tweak with the pre-installed binaries, so I'm trying not to do that.

I just tried running rclone as a standalone binary and it seems to work fine, not super intuitive but I think this should solve my issues. Thanks for your help!

I wouldn't recommend changing the preinstalled binaries as that will end up getting overwritten when they release an update and things can break.

It's much better if you have a spot to drop the binary and run from there if that's what you want to do.

i add alias to .bashrc
alias rclone='/path/to/rclone'