Docker compose volume with fast-list

What is the problem you are having with rclone?

I'm trying to used rclone as a volume in docker to mount a gdrive + crypt and pass it the fast-list option but I can't find how to pass it

Run the command 'rclone version' and share the full output of the command.

$ rclone version
rclone v1.58.0

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-48-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.8
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

gdrive + crypt

The command you were trying to run (eg rclone copy /tmp remote:tmp)

    name: "build_remote-rclone"
    driver: rclone:latest
      remote: 'GDriveEncrypted:'
      allow_other: 'true'
      vfs_cache_mode: full
      fast_list: 'true'
      poll_interval: 0

The rclone config contents with secrets removed.

type = drive
client_id = XXXXXXXXXXXX
client_secret = XXXXXXXX
scope = drive
root_folder_id = XXXXXXX
token = {"access_token":"XXXXXXXXXX","token_type":"Bearer","refresh_token":"XXXXXXXXX","expiry":"XXXXXXXXXX"}

type = crypt
remote = GDrive:
filename_encryption = standard
directory_name_encryption = true
password = XXXXXXXX

A log from the command with the -vv flag



When tryin gto spin up my docker compose, i got this :

$ docker-compose -f docker-compose.yml up
Creating volume "build_remote-rclone" with rclone:latest driver
ERROR: create build_remote-rclone: VolumeDriver.Create: unsupported backend option "fast_list"

Fast list does nothing on a mount.

Oh, ok, that make sense.

On a related note, I also have trouble to add the cache-dir option, same error, is it also not supported ?
Is there a list of supported option for the docker pluggin ?

Look down the page here for cache=

Yes I had seen this one, but it seem to be to set the cache for the whole pluggin.
Is there a way to do it per docker volume ? I will have multiple overlapping remove volume and I don't want to risk data corruption as stated in rclone mount

When you set the cache location, it doesn't overlap as it'll create an entry based on the remotes to the best of my knowledge.

I don't use the docker plugin as it's quite overkill imo as rclone is a single binary with a single file so I just run it as such.

@albertony might be able to answer as it's beyond me if possible or not.

I agree with everything you said except this... :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.