Disable per-minute update messages when using verbose level 1?

What is the problem you are having with rclone?

I run daily "sync" operations with a cron job, the source files change infrequently so most of the time no files are actually transferred, but if any files are transferred, I have to keep a log of it, meaning I have to use verbose level 1, otherwise files can potentially be transferred without being logged.

Recently I added another sync that takes longer than 1 minute to complete and the logs are becoming very cluttered

ordinarily a "nothing changed" job should have a very short log entry like this:

2024/01/12 19:52:45 INFO  : There was nothing to transfer
2024/01/12 19:52:45 INFO  : 
Transferred:              0 B / 0 B, -, 0 B/s, ETA -
Checks:             16304 / 16304, 100%
Elapsed time:        46.4s

but if a job takes longer than 1 minute I get this mess (filenames vary each time):

2024/01/12 19:54:24 INFO  : 
Transferred:              0 B / 0 B, -, 0 B/s, ETA -
Checks:             52412 / 62426, 84%
Elapsed time:       1m0.0s
Checking:
 * skyqueen/archive/71mas…/1277391226/index.html: checking
 * skyqueen/archive/71mas…kareha.pl/1277397250/2: checking
 * skyqueen/archive/71mas…kareha.pl/1277980103/4: checking
 * skyqueen/archive/71mas…/1278133680/index.html: checking
 * skyqueen/archive/71mas…kareha.pl/1277980103/9: checking
 * skyqueen/archive/71mas…umb/1292424254849s.jpg: checking
 * skyqueen/archive/71mas…/1277359068/index.html: checking
 * skyqueen/archive/71mas…/1278133699/index.html: checking

2024/01/12 19:55:20 INFO  : There was nothing to transfer
2024/01/12 19:55:20 INFO  : 
Transferred:              0 B / 0 B, -, 0 B/s, ETA -
Checks:             96039 / 96039, 100%
Elapsed time:      1m56.5s

If a job takes multiple minutes complete it gets even worse

I could grep out "checking" before redirecting to the log, which would help somewhat, but what I'd really like to do is disable the per-minute messages entirely

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.1
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 5.15.0-83-generic (aarch64)
- os/type: linux
- os/arch: arm64 (ARMv8 compatible)
- go/version: go1.21.5
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Oracle Cloud Object Storage, mostly using it via S3 compatibility, because using it as "oracleobjectstorage" is several times slower

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone --exclude-from ~/exclude.txt -v --skip-links sync /var/www2 oracle:backup/www2/ 2>> /root/oraclelog

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[oracle]
type = s3
provider = Other
env_auth = false
access_key_id = XXX
secret_access_key = XXX
endpoint = xxxxxx.compat.objectstorage.xx-xxxxx-1.oraclecloud.com
acl = private

[oracle2]
type = oracleobjectstorage
provider = user_principal_auth
namespace = XXX
compartment = XXX
region = xx-xxx-1
config_file = ~/.config/rclone/oci.txt

A log from the command that you were trying to run with the -vv flag

see above

Use --log-file flag:

rclone sync .... --log-file=/path/to/log

instead of recording rclone output.

You can use --stats 1y and you'll get one per year, and the summary at the end.

You can also change the log level of the stats with

  --stats-log-level LogLevel            Log level to show --stats output DEBUG|INFO|NOTICE|ERROR (default INFO)

So --stats-log-level DEBUG will hide them completely with -v - this won't get you the summary at the end.

Though that said a lot of people like

  --stats-one-line                      Make the stats fit on one line

To make a single log line once per minute so you can see stuff is happening.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.