Directory issues

What is the problem you are having with rclone?

I have enabled the hard delete in Mega mount. I deleted a file, but somehow even after deleting it still showed up later. Only after unmount and remount it went away. I used vfs cache mode full.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount - - vfs-cache-mode full Mega:/ L:

The rclone config contents with secrets removed.

I have all defaults, except hard delete enabled. 

A log from the command with the -vv flag

Paste  log here

can you try on a mount without --vfs cache-mode and without --mega-hard-delete

without a debug, hard to know what is really going on.

Okay. I will try that

are you using windows explorer?

after deleeing the file, can you try refreshing the file manager. perhaps switch to another folder, then switch back to the original folder

the default value for --dir-cache-time is 5m.
so if you delete a file, wait six minutes, refresh the file manager, refresh the file manager, does the deleted file go away?

Yes Windows explorer. I am new to rclone and not really a programmer. I am not able to replicate the bug again for unknown reasons.

Okay. Will keep in mind about the 5 minutes thing.
I was simply playing videos i had in my mega and deleting as i watched ome completely. But noticed few times that deleted file was still showing after i deleted using windows explorer. The thing worked fine after unmount and remount. I had not noticed this issue before enabling hard delete. I had vfs cache mode full before that. Probably hard delete related.

Will report if I see this issue again. How do i get the debug report?

I had switched folders and refreshed folder too... The file had still shown. And the cmd.exe showed i/o errors that it could not access file?

can you post that?

for a debug log, --log-file=log.txt --log-level=DEBUG

It doesn't have any confidential information right?

nothing about id, secrets, passwords and such.

it will contain the name of the files but you can cut and paste into a text editor and change the filename to filename.file

would want to see the top 20 lines of the debug file and the errors.

this is the log file. the issue came again.

sorry, i tried that site and it does not look safe, very creepy and soft porno pop-ups.

most rcloners use!qAp2nYAT!DD70rNlGK4ercJOH-FKdB3li3dglAxwWfZaVHPxP-KQ

I hope this is fine?

what was the name of the file?

Hmm. I deleted some image files... Jpgs... They came back... And there were video files.... In K2... They also showed up after deleting and in bring on ghost too.
Sorry didn't note the names of the files

The items get deleted fine. They are permanently deleted. But the issue is they still show up in explorer. They can't be opened. It may be an issue about waiting for 5 minutes i guess. Idk.. Hadn't noticed this when hard delete configuration was disabled

ok. do some more testing, if it happens again, post a debug log with the name of the file.

the debug log can get very large.
if you are running rclone via a batch file, i would delete the log before running rclone.

Hmm. Okay. Will do that.

i just took a look at the log; there are errors in it.
now that we have the debug log; we have expert at analyzing that and i am sure one will stop by soon.

2021/04/14 22:55:37 DEBUG : IMG-20150520-WA0004.jpg: File.Remove file error: Remove object failed: Object (typically, node or user) not found
2021/04/14 22:55:37 DEBUG : IMG-20150520-WA0004.jpg: >Remove: err=Remove object failed: Object (typically, node or user) not found
2021/04/14 22:55:37 ERROR : IO error: Remove object failed: Object (typically, node or user) not found
2021/04/14 22:55:37 DEBUG : /IMG-20150520-WA0004.jpg: >Unlink: errc=-5

Yes thats the error that was showing! Thanks!

Is it a shared object? Or maybe not owned by you?

Nope. Those images were uploaded by me to Mega account. The other files were imported to the account from mega links found somewhere.