Difficulty transferring large number of files from Mega to Google Drive using rclone

What is the problem you are having with rclone?

I have a 14 TB Mega link with 2,182,723 files and 68,978 folders. It is not opening in rclone, and I want to transfer all of the content to my Google Drive account. I have unlimited storage in Google Drive, but it's difficult for me to transfer from Mega to Google Drive. Do you have any suggestions or recommendations for how to fix this? I am trying to do this in 10 gpbs speed on a VPS with 6 cores and 16GB ram
Also, what flags can I add to extend the time for Mega to load in rclone?

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

Which cloud storage system are you using? (eg Google Drive)

MEGA and Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd mega:

The rclone config contents with secrets removed.

type = mega
user = email
pass = pass

A log from the command with the -vv flag


hello and welcome to the forum,

can you post a debug log.
add -vv to the command and post full output

Failed to create file system for "megas:": couldn't login:
that is a common issue in the forum and documented at

possible workarounds:

hey @asdffdsa thanks for the reply, here is the debug log

2023/04/29 13:58:38 DEBUG : rclone: Version "v1.62.2" starting with parameters ["rclone" "lsd" "megas:" "-vv"]
2023/04/29 13:58:38 DEBUG : Creating backend with remote "megas:"
2023/04/29 13:58:38 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2023/04/29 13:58:49 Failed to create file system for "megas:": couldn't login: Try again

nothing rclone can do about that.
have to workaround it.

i would choose rclone mount over rclone over megacmd webdav server.
in either case, rclone has ways to verify file transfer.

with rclone mount, an extra step, rclone compares md5 of source and dest.
in your case:
--- source is the file inside the rclone mount cache
--- dest is gdrive

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.