Defaults ... root ... file section


#1

it appears this message when i try to mount GDrive to a local folder

Config file “/root/.config/rclone/rclone.conf” not found - using defaults
Failed to create file system for “xxxxxx:”: didn’t find section in config file

new remote created with own OAuth
the similar topics dont understand


#2

It means your rclone.conf is missing.

If you run:

rclone config file
Configuration file is stored at:
/opt/rclone/rclone.conf

You need to run rclone config and validate the file is there.


#3

how i validate ?
ubuntu 18.04 x64 in a dedicated oneprovider xeon


#4

I listed the command above my post. You run “rclone config file” which shows the location of the file.

The message is telling you it doesn’t exist and you need to run “rclone config”


#5

i have a remote created …
and i can’t run config without root permissions
…perhaps i need to do some quit of operations before?


#6

What user are you logged in as? What user did you run ‘rclone config’ as?

The error message says you are starting as the ‘root’ user and I don’t understand that if you don’t have access.

You want to run as rclone as the same user you ran rclone config as.


#7

i just installed this new machine
there’s nothing installed, except rclone , unzip and that’s all
rclone installed via curl script from the web with an admin user, rclone remote created with normal user again …
the new mount are impossible to run (see first post) … then i try to re-validate the rclone.config again and i’m not able to run it again.
i think i’m gonna re-install via web to a fresh new ubuntu install


#8

I think you are getting confused on users and reinstalling won’t help that.

In Unix, you have users. If you installed it as a user called ‘admin’ and ran rclone config as ‘admin’, you want to start the process as admin.

If you want to run as ‘root’, which is fine, you need to run rclone config as the ‘root’ user. The rclone config is stored in the user’s home directory that you run the process as.

Can you not login as the ‘root’ user and run rclone config?

How are you trying to start rclone? From a terminal window? From something else?


#9

thanxs for your patience
… assuming i create the remote with the root user … it’s fine to open rclone config
… assuming i want to mount with sudo rclone mount pointing the config file stored (presumed) in the root folder … must be working?
didn’t run !

if i try to do the same with the config file stored in the home/xxxx fails too

if i try to sudo rclone mount pointing the config file to the /home/xxxx system freezes !


#10

I’m not sure what you are doing as you aren’t providing any detail information.

If you want to run as the root user.

Log in as root
Run ‘rclone config’ and enter in your information
Run 'rclone mount remotename: /mountpoint

If you want to run as a different user, you’d run those exact same things as the user.

“sudo” means execute a command as the root user. If you didn’t run rclone config as the ‘root’ user, it would generate the first error you shared as you don’t have a config file for it.

So my example, my user is felix. I store my file in a location shown by the command, I can list my remote called gcrypt:

[felix@gemini ~]$ rclone config file
Configuration file is stored at:
/opt/rclone/rclone.conf
[felix@gemini ~]$ rclone lsd gcrypt:
          -1 2018-06-17 10:24:02        -1 Movies
          -1 2018-06-17 09:16:39        -1 Radarr_Movies
          -1 2017-04-18 16:14:26        -1 TV
          -1 2018-06-30 12:55:49        -1 TV_Ended
          -1 2019-03-10 19:10:41        -1 deleteme.file

and I use the following mount:

/usr/bin/rclone mount gcrypt: /GD --allow-other --buffer-size 512M --dir-cache-time 96h --drive-chunk-size 32M --log-level INFO --log-file /var/log/rclone.log --timeout 1h --umask 002 --rc

That runs as my user felix.

[felix@gemini ~]$ ps -ef | grep rclone
felix      639     1  2 Mar08 ?        01:20:05 /usr/bin/rclone mount gcrypt: /GD --allow-other --buffer-size 512M --dir-cache-time 96h --drive-chunk-size 32M --log-level INFO --log-file /var/log/rclone.log --timeout 1h --umask 002 --rc
felix    18195 13597  0 09:31 pts/1    00:00:00 grep --color=auto rclone

#11

thanxs again
finnally i did it
sudo rclone mount pointing to the /home/user with &
opening another putty instance it worked
i’m gonna try VFS caching

sudo rclone mount remote: /home/xxxxxx/folder --dir-cache-time 240h --vfs-read-chunk-size 16M --vfs-read-chunk-size-limit 64M --allow-other -v --config="/home/xxxxxx/.config/rclone/rclone.conf"&


#12

If you created the config as a user, why would you not just run it as that user? What’s the reason for running it as root?


#13

because didn’t work!
…at this point i don’t remember how i created the remotes. it was yesterday very late night.
i’m really sure was without root (as you are mention) …but the mount doesnt worked
thanks again
…tomorrow im gonna try it again without sudo rclone mount


#14

What didn’t work? What command did you run? What did you enter into the terminal to try to use it?

By all means, continue to run as root if you’d like as I’m just saying it’s not best practice nor advised.


#15

i know it’s not the best practice to run things as root
… this morning i want to redo the mount without the sudo
but, its gonna be a complicated morning
thxs again