Deccrypted Mount Stopping and Unsuable

I set up my Plex Server on Ubuntu 16.04.3 and both the encrypted mount and unencrypted mount from my remote were working. I was able to use rclone to upload my media to my remote server and the Plex app was able to see the remote mount and play all the media contained on it. Then after the last upload, the unencrypted mount stopped working.

Now when I mount the encrypted drive I can still navigate to it and see the encrypted files and folders, but when I mount the decrypted drive, it stops the process as soon as I try to navigate to it and mounting it does not make the media stored on the server usable by Plex. I have tried deleting and re-configuring the decrypted mount, but with no success. Has anyone else run into this and, if so, what was your solution?

The text snippet below is what I’m am getting from the CLI and the current state of my rClone configuration (with the sensitive data redacted).

myka@plex-server:~$ cd plexdrive
myka@plex-server:~/plexdrive$ ./plexdrive-linux-amd64 mount -o allow_other /mnt/plexdrive &
[1] 31503
myka@plex-server:~/plexdrive$ cd
myka@plex-server:~$ cd /mnt/plexdrive
myka@plex-server:/mnt/plexdrive$ ls
myka@plex-server:/mnt/plexdrive$ cd
myka@plex-server:~$ sudo /usr/bin/rclone mount --allow-other uncrypt: /mnt/media &
[2] 31582
myka@plex-server:~$ cd /mnt/media
[2]+  Stopped                 sudo /usr/bin/rclone mount --allow-other uncrypt: /mnt/media  (wd: ~)
(wd now: /mnt/media)

type = drive
client_id =
client_secret = myClientSecret
service_account_file =
token = {"access_token”:myAccessToken”,”token_type":"Bearer","refresh_token”:”myRefreshToekn”,”expiry”:”expiryDayTime”}
type = crypt
remote = pserv:private1
filename_encryption = standard
directory_name_encryption = true
password = myPassword
type = local
nounc =
type = crypt
remote = pserv:private1
filename_encryption = standard
directory_name_encryption = true
password = myPassword
password2 = mySalt

Try running this command without the & and see what logs get produced.

So I ran the mount command with debug logging enabled and no “&” and there was an issue with the the salt having been overwritten, which I fixed. I ran the mount again with debug logging just to be sure and it worked perfectly.

But when I went back to running the mount in the background it is showing the same stopping behavior as I described in the original post. I tested both ways a second time and it seems to only be exhibiting this behavior when I run the process in the background.

My installation is Ubuntu is CLI Only so I am unable to run multiple processes without sending them to the background, so I am more or less back where I started.

@MykaMart I am quite a beginner with Ubuntu, but shouldn’t it be:

nohup sudo /usr/bin/rclone mount --allow-other uncrypt: /mnt/media &

to have a working background process? Otherwise it will stop if you do anything else on the terminal.

“nohup” keeps a process going after a logout or the shell is exited, but does not allow for additional input in the terminal.

“&” allows for running the process in the background leaving the terminal free and was working previous to the issues described in my original post. Also, as I mentioned, it is not just a matter of the process stopping when I run the mount in the background, it is also not properly mounting when I use “&”. Navigating to the folder through an ssh session shows the mount folder to be empty which is not the case when I run the command as the sole process.

1 Like

That might be because it is trying to read from standard input - do you have a password set on the config file?

You could try redirecting the input and output - some shells don’t let processes write stuff in the background - that might help so add </dev/null >rclone.log 2>&1 on the end of the command.

You could also try screen which would solve the problem too, and let you log out and keep everything running.