Crypt doesn't work?

What is the problem you are having with rclone?

Crypt doesn't seem to work. First I've setup my OneDrive (folder) connection, that is working fine. After that I've setup a crypt folder as a subfolder (onedrive:encrypted) in my OneDrive. I seems to work but when I copy a file to the encrypted folder on OneDrive the file shows up in a non-encrypted state. Tried many configs without any success, below my desired config. I can't figure out what I'm doing wrong?

Rclone verion

rclone v1.57.0

  • os/version: slackware 14.2+ (64 bit)
  • os/kernel: 5.10.28-Unraid (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Microsoft OneDrive (for Business)

The rclone config contents with secrets removed.

type = crypt
remote = onedrive:encrypted/folders
filename_encryption = standard
directory_name_encryption = false
password = PW
password2 = PW2

A log from the command with the -vv flag

rclone copy Ebooks onedrive:encrypted/folders -P -vv
2022/01/23 17:18:05 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rcloneorig" "--config" "/boot/config/plugins/rclone/.rclone.conf" "copy" "Ebooks" "onedrive:encrypted/folders" "-P" "-vv"]
2022/01/23 17:18:05 DEBUG : Creating backend with remote "Ebooks"
2022/01/23 17:18:05 DEBUG : Using config file from "/boot/config/plugins/rclone/.rclone.conf"

You have to copy to your encrypted remote name not the base remote.

So change onedrive:encrypted/folders to encryption:

Oh my bad, so noob. Spend hours of finding a solution. Thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.