Cronjob with encrypted rclone.config file

#### What is the problem you are having with rclone?

Can't mount remote using an encrypted rclone.config

#### What is your rclone version (output from rclone version )

rclone v1.49.1

#### Which OS you are using and how many bits (eg Windows 7, 64 bit)


#### Which cloud storage system are you using? (eg Google Drive)

Google drive

Hi there,
I just opened a new topic as the current problem is somehow different to my last question.

I use a cronjob to run daily backups. My rclone.config is encrypted and as noted in the docs I have to put in my config pw... accordingly, I modified my script that it looks like this:

if pidof -o %PPID -x ""; then
exit 1
export RCLONE_CONFIG_PASS=mypassword
sudo rclone snyc.... --flags.... --ask-password=false

I saw that someone suggested to add the line "export RCLONE_CONFIG_PASS=mypassword" just above the rclone command.

However, whenever I run the script - manually or via cron - I got the following error:

line 2: mypassword: command not found

Furthermore, my rclone.log states that I must set the RCLONE_CONFIG_PASS.
btw: setting "RCLONE_CONFIG_PASS=mypassword" above the other line produces more errors.

Any suggestions? :slightly_smiling_face:

This topic seems very similar to one we just had. I'd suggest before asking for more help here you check if maybe you find the solution already explained here:

(if not then ask again here rather than highjacking the other topic)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.