Create rclone remotes with longer remote names

What is the problem you are having with rclone?

When I defined a new remote for Google Drive and gave it a name as "googleDriveVivjain604Shared", when I mount this remote drive using 'rclone mount', then in my windows system the drive name is assigned as 'googleDriveVivjain604Shared{ysOI'. (The last five character are automatically picked up, either by windows or rclone).

This new drive name cannot be used in rclone CLI commands since '{' character is now allowed in the name of remote in rclone commands.

Run the command 'rclone version' and share the full output of the command.

rclone v1.67.0
- os/version: Microsoft Windows 11 Pro 23H2 (64 bit)
- os/kernel: 10.0.22631.3593 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.22.4
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy --server-side-across-configs --metadata googleDriveVivjain604:Limelight_Music_School\Templates googleDriveVivjain604Shared{ysOI:\Limelight_Music_School_Operations\Templatex -vv -P --log-file rclcone_0003.log

The 'rclone config'

Current remotes:

Name                 Type
====                 ====
googleDriveVivjain604 drive
googleDriveVivjain604Shared drive

A log from the command with the -vv flag

2024/06/16 17:27:37 DEBUG : rclone: Version "v1.67.0" starting with parameters ["rclone" "copy" "--server-side-across-configs" "--metadata" "googleDriveVivjain604:Limelight_Music_School\\Templates" "googleDriveVivjain604Shared{ysOI:\\Limelight_Music_School_Operations\\Templatex" "-vv" "-P" "--log-file" "rclcone_0003.log"]
2024/06/16 17:27:37 DEBUG : Creating backend with remote "googleDriveVivjain604:Limelight_Music_School\\Templates"
2024/06/16 17:27:37 DEBUG : Using config file from "C:\\Users\\Radix Childcare\\AppData\\Roaming\\rclone\\rclone.conf"
2024/06/16 17:27:37 DEBUG : Google drive root 'Limelight_Music_School/Templates': 'root_folder_id = 0AOzID7yI6u4JUk9PVA' - save this in the config to speed up startup
2024/06/16 17:27:38 DEBUG : fs cache: renaming cache item "googleDriveVivjain604:Limelight_Music_School\\Templates" to be canonical "googleDriveVivjain604:Limelight_Music_School/Templates"
2024/06/16 17:27:38 DEBUG : Creating backend with remote "googleDriveVivjain604Shared{ysOI:\\Limelight_Music_School_Operations\\Templatex"
2024/06/16 17:27:38 Failed to create file system for "googleDriveVivjain604Shared{ysOI:\\Limelight_Music_School_Operations\\Templatex": config name contains invalid characters - may only contain numbers, letters, `_`, `-`, `.`, `+`, `@` and space, while not start with `-` or space, and not end with space

1 Like

this is not a bug. when you post, please use the help and support template, not suspected bug

never a reason to use the temporary remote name created by rclone mount.
only use the names from the config file as shown by rclone listremotes

are you trying to copy a file to the mount?
if so, need to use the drive letter from the mount command.


Thanks. Noted. We can mark it closed as this is not a bug.



you can close it yourself, mark the post that solved the issue as the solution

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.