Create date on folders gone after rclone restart

I have a issue with rclone + dropbox. Every time i restart the mount i get todays date on the folders. So all sorting etc is impossible. As long as its up the dates are there when i create a new folder. But gone after restart. Files in the folders are fine.

Worked fine with gdrive.

rclone v1.62.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-73-generic (x86_64)

rclone does not support modtime for folders AFAIK

There is plenty of open github issues related to this, e.g.:

Oh. Worked fine with gdrive. But thats not because of rclone i guess.

Dropbox doesn't have it available in the API I believe or did not when it was first implemented possibly as well.

I use the beta for now and use:

--default-time 2023-01-01

So any 'old' folders always get that time instead of the mount time. Any 'new' folders would have a current timestamp on creation.

What is interesting is that when I login to dropbox web interface I can see folders mod times

so yes there might be that rclone is not perfect here. By legacy implementation of Dropbox API or by design I am not sure

I haven't rechecked as it is present in the data, just not sure if the API supports it now or not.

Hi, that "--default-time 2023-01-012 is available in mount command too?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.