"Couldn't initialise SFTP" on a Windows system

I’ve been successfully using rclone for about a year to backup a Windows 10 system to a remote NAS using WebDAV. It’s been working brilliantly, but lately I’ve become frustrated with the fact that WebDAV doesn’t sync modification times. So I want to switch to SSH/SFTP instead. However, I can’t seem to connect using rclone 1.42:

C:\Stuff>rclone lsd myremote:
2018/08/30 14:09:27 Failed to create file system for "myremote:": NewFs: couldn't initialise SFTP: ssh: subsystem request failed

This is my config file (anonymized):

type = sftp
host =
user = backup
port = 
pass = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
key_file = 
use_insecure_cipher = false
disable_hashcheck = 

When I ssh to my NAS using the same credentials in either Putty or the new built-in ssh client in Windows 10 everything works fine. Not sure if this is relevant, but the first time Iog in with a new client I get something like this:

The authenticity of host ' (' can't be established.
ECDSA key fingerprint is SHA256:xxxxxxxxxxxxxxxxxxx/xxxxxxxxxxxxxxxxxxxxxxx.

Is there something obvious I’ve missed?

I think that means that rclone asked for the sftp subsystem and the NAS said no.

Does it need to be enabled or something?

Have you tried sftp-ing from your windows computer? Eg with Filezilla.

I was almost going to send a semi-snarky reply pointing out that if you read my original post you’ll see that SSH-ing from my windows machine works perfectly - when I noticed that you wrote SFTP and not SSH. And that made me think. I honestly thought that SFTP would automatically work when you had a working SSH connection. So I tried FileZilla as you suggested: no connection. Then I dug through the admin interface of my NAS and eventually noticed that the SFTP service was disabled. I enabled that and voila, working SFTP from Filezilla, working rclone from Windows!

Or at least sort of. Now I’m having other problems (random EOFs, transfers locking up without completing) but I’ll start a new thread for that once I’ve tried a bit more debugging. But thank you very much for pointing me in the right direction!

Great - glad you got that part working!

It is worth testing with the latest beta too if you have having problems. (It will beome 1.43 over the weekend most likely!)