Could not open google drive download in Windows

In Linux, I set up a rclone share with Google Drive, and it downloaded everything onto a NTFS partition. So far, so good. But then when I booted into Windows, Windows Explorer could not open the folder. It saw the folder, but could not open it.

I am currently running rclone and rclone browser on MX Linux AHS 19.3 x64 (based on Debian 10)

rclone v. 1.53.2

rclone config
Current remotes:

Name Type
==== ====
shiureiharavbelsky drive


when you try to open those files in windows explorer, what happens.
does windows explorer complain, can you post a screenshot?

you can run rclone, using the same config file, on windows, and download the files that way.

There is not much to show in a screenshot. When I double-click on the folder in Windows, it will not open. It is like a dead icon.

My goal is to have a local folder that is accessible from both Windows and Linux, regardless of which platform I used to make changes.

i assume that you are using a dual boot system or an external usb drive?
the odds are there is something wrong with the nfts emulation on linux system or a file permission issue
you could try to change the file permissions to your username or to everyone.

another option, perhaps better is to mount shiureiharavbelsky as a local drive letter.
x: would be a virtual drive, the files are still on gdrive, but appear to be local.

you could stream the shirium that way.
rclone mount shiureiharavbelsky: x: "--vfs-cache-mode=full

you would need to install this first,

So I tried syncing a different folder and everything works just right.
I think the problem was the fonts in the Hebrew name of the folder, because I started to get this error in Windows:
"the file name, directory name, or volume label syntax is incorrect"
My guess is that one or more of the Hebrew characters in the name wasn't recognized by Windows, for some reason.

1 Like

did you try?

  • using windows, to download the files
    once again, download from linux, reboot in windows

when you first posted, you should have been asked for information.

so can you please post it now, including a debug log

What is the problem you are having with rclone?

What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

So the whole problem turned out to be a quote mark that was used in the top folder name, and that is invalid in Windows, but allowed in Google Drive, as well as in Linux. Once I removed the offending characters, accessing the folder from Google Drive online, no more problems. In the end, I don't think it had anything to do with Hebrew.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.