Copying from Dropbox to an external drive failing

What is the problem you are having with rclone?

I'm attempting to use rclone installed on a Raspberry Pi (running Raspberry Pi OS) to backup my entire Dropbox to an external HD (connected to the Pi via USB).

The command does work if I connect the drive to my Mac so not sure what the issue is. Some kind of permissions problem?

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0
- os/version: raspbian 11.2 (64 bit)
- os/kernel: 5.10.92-v8+ (aarch64)
- os/type: linux
- os/arch: arm64
- go/version: go1.17.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync dropbox: /media/pi/BLOBBY/DropboxBackup -P

The rclone config contents with secrets removed.

type = dropbox
token = {REMOVED}

A log from the command with the -vv flag

Goes through every file and either skips or errors as in the second line below:

2022/02/10 12:50:42 DEBUG : Abi/Documents/My Great DVD.dvdproj/Contents/PkgInfo: Unchanged skipping
2022/02/10 12:50:43 ERROR : Me on Podcasts:Radio/Rare FM Files/Recoverd_mp3_file(10443).mp3: Failed to copy: mkdir /media/pi/BLOBBY/DropboxBackup/Me on Podcasts:Radio: invalid argument

hello and welcome to the forum,

most of the answers to the help and support template questions are missing?
hard to share a good answer.

can you post a full debug log?

/media/ - that exists path exist on the mac?
make sure rclone ls works

Hi, I've updated with the template answers - the full log is essentially either files being skipped because they already exist or failing with the 'invalid argument' error.

The media path only exists on the Pi, on the Mac I use the equivalent path for mounted USB volumes.

rclone ls works and lists all my files

-- that rclone version for the pi, is missing the top line, still do not know the exact version.
-- the mac rclone version is missing?
-- for a file that failed, using the system file manager, can that file be coped to the same folder on the usb volume?
--- have you checked the usb volume for errors?

--- need to see a debug log, ok?
if the same file fails each time, copy that single file and post the full debug log.
if not, then take the full debug log, and cut out of most of it and post that.

Apologies, formatting error hid the version line. Mac has same version.

I can copy files to the volume - in fact if I share it over the network I can actually run rclone on the mac pulling the files from the Dropbox and saving them on the drive over the network, so it isn't a problem with the drive as far as I can see.

I could paste more of the debug log but it's thousands of lines that are either "Unchanged skipping" or "Failed to copy" - exactly the same as either of the above. Unless there's some other log I should be looking at?

i think the issue is that the mac cannot handle directories/files with a :, colon character.

Ah, I think that's it - it's actually labelled as "Me on Podcasts/Radio", the slash gets translated into a : I think - it isn't an issue if I run rclone on the mac, but it causes the error on Pi OS - if I rename that folder the errors stop. Is there a way around this other than just watching for errors/renaming files?

sorry, confused, i thought that problem occured on the mac.
so the issue is with pi?

linux can handle the colon character

The issue is with the Pi, rclone sync was working fine on the Mac without throwing errors on that folder name.

For some reason the colon character is causing the errors on Pi OS - I renamed the folder and the errors stopped. One other error popped up about a file with a question mark in the name - again, renaming it fixed it.

perhaps try ---local-encoding

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.