Copy progress help?

So I have been running a copy operation on my drive to an encrypted cloud backup for about 10 hours now. Is there anyway to see how many GB have been processed, GB remaining, % remaining, or the files currently being encrypted and uploaded?

Also, If I put my laptop to sleep and reconnect it later will the download resume properly on it’s own, or will I be likely to get some time out error and have to start over? It’s quite late for me and I am currently set up in my schools computer lab.

clone -v --bwlimit=8M copy src dest

-v gives a nice status of things every minute

2018/04/08 08:58:14 INFO :
Transferred: 273.340 GBytes (7.548 MBytes/s)
Errors: 0
Checks: 0
Transferred: 43
Elapsed time: 10h18m0.4s

1 Like

As @Code-Slave said, the -v option is required to show progress. Add --stats 30s to see the progress every 30 seconds if you don’t want the default of every minute (change 30s to 5m or 20s or whatever you want).

Unfortunately, it won’t show you the progress of ALL copies. What I mean is that rclone has no idea whether it has 1 more file to copy or 1,000 more files. GUI OSs like Windows and MacOS spend a LONG time counting files before the first bit is moved so that they can count down from 1,000 files to copy down to 0. Rclone–and most command line utilities–simply starts copying the moment it sees a file that meets the copy parameters while still checking files in the background. Of course, if you already know that you have 100 GB to copy and “Transferred” shows 95 GB, then a good guess would be that you have 5 more GB to go!

You don’t mention what OS you’re using. I run all my Linux sessions inside TMUX which means that if my laptop goes to sleep or I log out or I lose power, my session continues unabated. I can even transfer my terminal from one computer to another without killing off a remote connection to a Linux box running an rclone copy.

Ah, thanks, I do know the size in GB should be around 231GB. I’m on windows and I’m just backing up the entire drive(though it is missing stuff that is protected by windows permissions from the looks of it) to an encrypted remote on box in the cloud. Looks like putting it to sleep just paused the connection which is what I was hoping for. That -v flag will be very useful when I copy my secondary drive to the cloud(roughly 900 GB). I imagine restoring from the copy will likely be a pain though as it will be missing all the files windows is protecting. But I’m actually going to try re-installing a bunch of stuff anyway and restructuring my files and everything which is shy I wanted the backup and I found rclone. It is leagues better than duplicati which I tried last week(spent 5 days on a transfer and aside from what looked like metadata nothing even uploaded) After this I have to copy around 900GB. Is there some way to cancel the copy, and then restart with the -v flag and not overwrite already uploaded files? That is, like, skipping them so I don’t have to start from the beginning of the upload? If not it’s not a huge deal, would just be nice and thought maybe someone knows if it’s possible with rclone?

Likely what will happen is the file you were transferring will fail, but it will carry on after a while just fine.

1 Like