Copy only files

What is the problem you are having with rclone?

Good morning,
I'm looking for a solution to copy only the files that are in the folders, without copying the folder itself. I tried several variants but I can't find the solution.

Run the command 'rclone version' and share the full output of the command.

rclone copy -P --files-only --exclude '*.{nfo,!qB}' "/home/snowtechnical/downloads/qbittorrent/AUptobox" uptobox:ZSeedbox

The flag --files-only that I have seen on some articles does not work

I'm on Rclone Version 1.62.2

Thank for help

It can be done in two steps:

rclone lsf source: > ListOfFiles.txt
rclone copy source: dest:  --include-from=ListOfFiles.txt
1 Like

Thank you for your answer, I tried but rclone will not look for files that are in the following folders
I found this solution that works for me

find source: -type f ! -name '*.nfo' ! -name '*.!qB' -print0 | xargs -0 -I {} rclone copy -P {} dest:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.