Copy from GDrive To Harddisk

Hello first of thanks for this awesome tool i got a lil question i got a few TB saved on GDrive now 1 of my hdd died now i need to redownload a lot of my files all are in folders with a few files in it to my pc is there a way to stop rclone to check every folder every time i start copy again ? i run command like this

rclone copy GDrive: D:\backup\ -P --exclude-from C:\rclone\skip.txt

where skip is a list of all folders i have on my other hdds so i want only copy my missing folders

skip list is like this

etc ...

running since 18 hrs again and it looks like this


hope you unterstand what i mean english is not my default language :smiley:

hello and welcome to the forum,

not sure there is a way to do that.
rclone has to compare the source and dest to decide what needs to be download.
this might help to speeds the compare

if you were doing a one time transfer this might help.

if you want the local disk to match gdrive, then you might want to use rclone sync

hi thanks for your answer

when i run it with --fast-list nothing is happening even when i run it more then 10 hrs

when i run it with --no-check-dest will it still use the --exclude-from filter ? because i dont want download everything only my missing folders

sry im a bit newbie with rclone

if you want the local disk to match gdrive, then you might want to use rclone sync

i want it the exact other way download my missing stuff from gdrive to my hdd

--no-check-dest, is not an option in your use-case.
i was pointing out that if you were doing a first-time transfer and the dest is empty, then you could use that flag.

when you first posted, you were asked for information, including a debug log.
the debug log will show what is going on.

ok can post a debug log everything is working fine i use my own google api its downloading everything and so on thats why i thougt i dont need 1

what i try to ask if there is a way that rclone create and index of what its already downloaded that it not check that on the next start of rclone copy command ? hope u understand now what i mean :X dunno how to proper type it sry

like i stopped it at folder 430 then when i start copy command again a i where at folder 430 lets begin with folder 431 and not start from folder 0 again and recheck them again

rclone does not create an index, so rclone will have to check every time it is run.

if you have several TB of small files in gdrive, the download process will be very slow.
as per the docs
"rclone to be limited to transferring about 2 files per second only. Individual files may be transferred much faster at 100s of MBytes/s but lots of small files can take a long time."

make sure you have done this

ok thanks yeah i run own id already thought there is something i didnt find or there maybe a commmand for that :frowning: thanks for your help

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.