Copy files in local mode to a NAS

What is the problem you are having with rclone?

I would like to copy files from a directory on my NAS to another directory on the NAS

Run the command 'rclone version' and share the full output of the command.

root@truenas[/]# rclone version
rclone v1.53.1-DEV

Which cloud storage system are you using? (eg Google Drive)

local mode

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync source:/mnt/volume1/PUBLIC dest:/mnt/volume1/SERVEUR

The rclone config contents with secrets removed.

I don't know how to create the config file in local mode. Everything works fine in remote mode Google Drive example

A log from the command with the -vv flag

2022/07/10 15:26:26 Failed to create file system for "source:/mnt/volume1/PUBLIC": didn't find section in config file

I'm new to rclone have a nice day thank you for your help Richard :slight_smile:

hello and welcome to the forum,

for local, a remote is optional, try using
rclone sync /mnt/volume1/PUBLIC /mnt/volume1/SERVEUR

need to update to latest stable v.1.59.0 or at least v1.58.1

jojothehumanmonkey :slight_smile:
The cmd worked perfectly thank you very much.
But unable to install rclone version v1.59.0 in Ubuntu?
cd rclone-v1.59.0-freebsd-amd64
cd rclone /usr/bin
chown root:root /usr/bin
Post: root@truenas[/rclone-v1.59.0-freebsd-amd64]#
chown root:root /usr/bin
chown: root: illegal group name
chmod 755 /usr/bin

root@truenas[/rclone-v1.59.0-freebsd-amd64]# rclone version
rclone v1.53.1-DEV
I looked for how to do it but everything I tried failed!
Have a nice day and thank you for your help Richard :joy: :upside_down_face:


it looks like you downloaded the version for freebsd for truenas?

have you tried to install rclone using the install script?


I'm sorry but I wasn't very clear!
Truenas is under freebsd and I connect in ssh under Ubuntu or debian or the confusion for me. But rcloune is well installed under freeBSD. I tried everything but, I still have the same problem of writing right?
wget (Ok)
unzip (Ok)
cd rclone-v1.59.0-freebsd-amd64 (Ok)
sudo cp rclone /usr/bin/
Message: Sorry, user root is not allowed to execute '/bin/cp rclone /usr/bin/' as root on truenas.local.
sudo chown root:root /usr/bin/rclone
Message: Sorry, user root is not allowed to execute '/usr/sbin/chown root:root /usr/bin/rclone' as root on truenas.local.
sudo chmod 755 /usr/bin/rclone
Message: Sorry, user root is not allowed to execute '/bin/chmod 755 /usr/bin/rclone' as root on truenas.local.
If I understood the messages correctly as root I cannot write or modify the directory or the file?
All tests lead to the same result! I can't modify or write to the /bin directory?
Thank you for your help jojothehumanmonkey
My beginner level under Truenas and linux
Have a nice day Richard :joy: :upside_down_face: :slightly_smiling_face:


is there a reason for not using the link i shared?

as a workaround,
rclone is a portable app, does not need to be installed, just run it.

if i remember correctly, @jared is/was testing truenas

Because I tried it first and it didn't work. This is the first cmd I tried then I tried others and the result is always the same it can't write to /bin

i have never used truenas, tho they support rclone
i think truenas has built in support for rclone.

as i suggested, rclone is a portable app,
so for now, just run it from inside your home dir.
in fact, on my synology boxes, that is what i do

Installation of rclone with "TrueNAS-12.0-U8.1" is solved! :slightly_smiling_face:

-------------- Example of cmd under Ubuntu terminal --------------

Note: To install rclone you must be connected to a [user] account and not a "root" account
Error message: Sorry, user root is not allowed to execute '/bin/bash' as ​​root on truenas.local.

[user]@ST-A1-[user]:~$ sudo su
[sudo] password for [user]:
root@ST-A1-[user]:/home/[user]# ssh [user]@ --I log in with an account "[user]"
[user]@'s password:
Last login: Wed Jul 13 14:55:27 2022 from
FreeBSD 12.2-RELEASE-p14 325282c09a5(HEAD) TRUENAS
Welcome to TrueNAS
truenas% --I am logged in as "[user]"

-------------- Before installing rclone --------------

  1. If rclone is already installed but you want to upgrade to a new version or you are on a beta like me!
  2. rclone will not install!
  3. You must delete the two directories "/rclone-v1.59.0-freebsd-amd64"
    Path: /mnt/[volume1]/USERS/[user]/rclone-v1.59.0-freebsd-amd64 --From [User] account
    Path: /root/rclone-v1.59.0-freebsd-amd64 --From "root" account
    According to your installation
  4. Optionally save your "rclone.conf" file
  5. You must adapt everything between [] to your parameters
    [user]@ (is random)

--------------------- INSTALLING RCLONE -----------------------

cd rclone-v1.59.0-freebsd-amd64
sudo cp rclone /usr/bin/
sudo chmod 755 /usr/bin/rclone
truenas% rclone version
rclone v1.59.0

  • os/version: freebsd 12.2-release-p14 (64 bit)
  • os/kernel: 12.2-release-p14 (amd64)
  • os/type: freebsd
  • os/arch: amd64
  • go/version: go1.18.3
  • go/linking: static
  • go/tags: none

Here you have installed rclone via your favorite ssh terminal with "TrueNAS-12.0-U8.1"
Good day to all the rclone community thanks to you and to jojothehumanmonkey for his help :grinning: :upside_down_face: :joy:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.