Copy a folder with an apostrophe in the title from Dropbox to GDrive

I'm having as issue where I cannot copy a folder with an apostrophe in the title from Dropbox to a GDrive shared folder

rclone copy -vv --dropbox-impersonate "Dropbox01:Big Analytics's files" --drive-impersonate "Data Analytics:DA Backup"

The error I get is "error reading source directory: directory not found"
I'm running Rclone on a Ubuntu server.

I tried to rename the folder in Dropbox but it is over 8GB so it fails to rename it.
Any help is appreciated, I'm sure it's a syntax error but I'm lost with using linux


hello and welcome to the forum,

the issue should not be an apostrophe in the source

what happens with rclone lsd Dropbox01:

if you do a rclone config , what are the exact names of the remotes?

can you share the debug output?

II've worked out the issue but not how to resolve it

If I am on a windows computer and use Rclone I can run the following
clone copy -vv --dropbox-impersonate "dbox1:Analytics’s files/Home" --drive-impersonate "gdrive:"
That works fine

The issue looks to be the formatting of the apostrophe when I'm running Rclone on Ubuntu.
When I use Reclone and lsd to the folder the apostrophe appears different from what I can input from my keyboard and It will not allow me to copy and paste it.

That character you pasted isn't an ASCII character, it is a Unicode RIGHT SINGLE QUOTATION MARK' (U+2019). So you'll need to type exactly that on Ubuntu to copy it. You should be able to cut and paste it from this page (that is what I'd do) or you can probably type it using CTRL+SHIFT+U 2 0 1 9 ENTER

Does that help?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.