Connections per checker when using cryptcheck, hetzner storage box

What is the problem you are having with rclone?

How many sftp connections are supposed to be created per "checker" when using cryptcheck? I read it should be 1 connection per checker, but maybe that's different when using cryptcheck?
Also I assume the nonce read/download happens via a "checkers" connection and not a "transfers" connection?

When I run a cryptcheck:
rclone -vv --one-way --transfers=1 --checkers=6 cryptcheck /local/stuff/ hetzner-enc:/remote/stuff/
rclone is creating 11 connections to the sftp server. Checkers=7 creates 13 sftp connections.

I'm just trying to optimize the settings since Hetzner storage box has a connection limit. I read on this forum it's 10, but 12 seems to work. Above 12 connections I get a bunch of file read failures and sometimes ftp subsystem errors. I also had to remove fast-list.

If anyone has other suggestions of command tweaks to optimize with Hetzner storage box, I'd love to hear. Thanks.

v1.59.1, mac, 10.15.7, amd64

Which cloud storage system are you using? Hetzner Storage Box

The command

rclone -vv --one-way --transfers=1 --checkers=6 cryptcheck /local/stuff/ hetzner:/remote/stuff/  

Hmm, it looks like you are right that the nonce download effectively adds another connection per checker.

So that should be 2 connections per checker when using cryptcheck.

cryptcheck shouldn't do any transfers, so I think you are seeing 2 connections per checker plus another connection for something or other...

Note that this isn't an exact science - the internal code of rclone doesn't attempt to monitor connections in the sftp backend.

We could add a flag like this to the sftp backend

  --ftp-concurrency int    Maximum number of FTP simultaneous connections, 0 for unlimited

to limit it absolutely. However that flag is notorious for causing deadlocks in the ftp backend so needs some care.