Connecting to FTP from shared host

What is the problem you are having with rclone?

Trying to connect to FTP from shred-server (GreenGeeks), but cannot.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.0

  • os/version: unknown
  • os/kernel: 4.18.0-425.19.2.lve.el7h.x86_64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

FTP

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd TST:

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[TST]
type = ftp
host = XXX
user = XXX
pass = XXX
no_check_certificate = false```



#### A log from the command that you were trying to run with the `-vv` flag  
<!-- You should use 3 backticks to begin and end your paste to make it readable.  Or use a service such as https://pastebin.com or https://gist.github.com/   -->

2024/02/21 12:15:57 DEBUG : rclone: Version "v1.65.0" starting with parameters ["./rclone" "lsd" "TST:" "-vv" "--ftp-disable-epsv" "--dump" "bodies"]
2024/02/21 12:15:57 DEBUG : Creating backend with remote "TST:"
2024/02/21 12:15:57 DEBUG : Using config file from "/xxx/.config/rclone/rclone.conf"
2024/02/21 12:15:57 DEBUG : TST: detected overridden config - adding "{suApg}" suffix to name
2024/02/21 12:15:57 DEBUG : ftp ://X.X.X.X:21: Connecting to FTP server
2024/02/21 12:15:57 DEBUG : ftp ://X.X.X.X:21: dial("tcp","X.X.X.X:21")
2024/02/21 12:15:57 DEBUG : ftp ://X.X.X.X:21: > dial: conn=fshttp.timeoutConn, err=
2024/02/21 12:15:57 DEBUG : FTP Rx: "220 FTP Server ready."
2024/02/21 12:15:57 DEBUG : FTP Tx: "USER USER_NAME"
2024/02/21 12:15:57 DEBUG : FTP Rx: "331 Password required for USER_NAME"
2024/02/21 12:15:57 DEBUG : FTP Tx: PASS *****
2024/02/21 12:15:57 DEBUG : FTP Rx: "230 User USER_NAME logged in"
2024/02/21 12:15:57 DEBUG : FTP Tx: "FEAT"
2024/02/21 12:15:57 DEBUG : FTP Rx: "211-Features:"
2024/02/21 12:15:57 DEBUG : FTP Rx: " AUTH TLS"
2024/02/21 12:15:57 DEBUG : FTP Rx: " CCC"
2024/02/21 12:15:57 DEBUG : FTP Rx: " CLNT"
2024/02/21 12:15:57 DEBUG : FTP Rx: " EPRT"
2024/02/21 12:15:57 DEBUG : FTP Rx: " EPSV"
2024/02/21 12:15:57 DEBUG : FTP Rx: " HOST"
2024/02/21 12:15:57 DEBUG : FTP Rx: " LANG bg-BG;zh-TW;zh-CN;ru-RU;ja-JP;ko-KR;es-ES;fr-FR;en-US;it-IT"
2024/02/21 12:15:57 DEBUG : FTP Rx: " MDTM"
2024/02/21 12:15:57 DEBUG : FTP Rx: " MFF modify;UNIX.group;UNIX.mode;"
2024/02/21 12:15:57 DEBUG : FTP Rx: " MFMT"
2024/02/21 12:15:57 DEBUG : FTP Rx: " MLST modify
;perm*;size*;type*;unique*;UNIX.group*;UNIX.groupname*;UNIX.mode*;UNIX.owner*;UNIX.ownername*;"
2024/02/21 12:15:57 DEBUG : FTP Rx: " PBSZ"
2024/02/21 12:15:57 DEBUG : FTP Rx: " PROT"
2024/02/21 12:15:57 DEBUG : FTP Rx: " REST STREAM"
2024/02/21 12:15:57 DEBUG : FTP Rx: " SIZE"
2024/02/21 12:15:57 DEBUG : FTP Rx: " SSCN"
2024/02/21 12:15:57 DEBUG : FTP Rx: " TVFS"
2024/02/21 12:15:57 DEBUG : FTP Rx: " UTF8"
2024/02/21 12:15:57 DEBUG : FTP Rx: "211 End"
2024/02/21 12:15:57 DEBUG : FTP Tx: "TYPE I"
2024/02/21 12:15:57 DEBUG : FTP Rx: "200 Type set to I"
2024/02/21 12:15:57 DEBUG : FTP Tx: "OPTS UTF8 ON"
2024/02/21 12:15:57 DEBUG : FTP Rx: "200 UTF8 set to on"
2024/02/21 12:15:57 DEBUG : fs cache: renaming cache item "TST:" to be canonical "TST{suApg}:"
2024/02/21 12:15:57 DEBUG : FTP Tx: "PASV"
2024/02/21 12:15:57 DEBUG : FTP Rx: "227 Entering Passive Mode (X,X,X,X,9,93)."
2024/02/21 12:15:57 DEBUG : ftp ://X.X.X.X:21: dial("tcp","X.X.X.X:2397")
2024/02/21 12:15:58 DEBUG : ftp ://X.X.X.X:21: > dial: conn=, err=dial tcp X.X.X.X:2397: connect: connection refused
2024/02/21 12:15:58 ERROR : : error listing: dial tcp X.X.X.X:2397: connect: connection refused
2024/02/21 12:15:58 DEBUG : 4 go routines active
2024/02/21 12:15:58 DEBUG : ftp ://X.X.X.X:21: closing 1 unused connections
2024/02/21 12:15:58 DEBUG : FTP Tx: "QUIT"
2024/02/21 12:15:58 Failed to lsd with 2 errors: last error was: dial tcp X.X.X.X:2397: connect: connection refused


What I understood - I need to have config another port for tcp command (passive) port instead of 2397.
I'm also tried with "--ftp-disable-epsv" but got same error

P.S. I just replace here the sensitive information with x, and changed ftp:// to ftp ://

welcome to the forum,

as per greengeeks website, i would test with filezilla/cyberduck using their pre-confgiured config file.
once that is working, setup rclone using the settings from that config file.

I'm trying to connect FROM GreenGeeks server to another server using FTP on rClone

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.