Configuration pwd input does not prompt while using --config="dir" cmd


#1

Hi,
I already set rclone.conf file with a configuration password. It works as normal and it prompt out asking for password input via “rclone config” cmd. Unfortunately, it able to bypass configuration password after using option –config=“dir” (custom directory). Is this a bug or what?

Microsoft Windows [Version 10.0.17763.194]
© 2018 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>cd D:\Profile\Synced\Backup\programs\rclone

C:\WINDOWS\system32>D:

D:\Profile\Synced\Backup\programs\rclone>rclone config
2018/12/15 12:08:29 ERROR : Couldn’t decrypt configuration, most likely wrong password.
Enter configuration password:
password:
2018/12/15 12:08:51 Failed to read password: EOF

D:\Profile\Synced\Backup\programs\rclone>rclone config –config="…/rclone.conf"
Current remotes:

Name Type
==== ====
ETeamDrive crypt
GDrive drive
TeamDrive drive

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q>
D:\Profile\Synced\Backup\programs\rclone>


#2

I think it is likely you have an unencrypted config file at ../rclone.conf - there is no way rclone can access an encrypted config without the correct password, so I think you must have an alternate unencrypted config.


#3

Thanks for reply, however it still not working. I tried to change the password of rclone.conf in custom directory and it showed as “encrypted”. When I tried re-access again the rclone conf file, it directly move to configuration setting without prompt out password enter.
Recently i just upgrade and replace the rclone directory version from 1.43 to 1.45. (rclone.conf generated based on 1.43) .I just wonder will it be the version compatibility issue?

Microsoft Windows [Version 10.0.17763.194]
© 2018 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>D:

D:>cd D:\Profile\Synced\Backup\programs\rclone

D:\Profile\Synced\Backup\programs\rclone>rclone config --config="…/rclone.conf"
Current remotes:

Name Type
==== ====
ETeamDrive crypt
GDrive drive
TeamDrive drive

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q> s
Your configuration is encrypted.
c) Change Password
u) Unencrypt configuration
q) Quit to main menu
c/u/q> c
Enter NEW configuration password:
password:
Confirm NEW configuration password:
password:
Password changed
Your configuration is encrypted.
c) Change Password
u) Unencrypt configuration
q) Quit to main menu
c/u/q> q
Current remotes:

Name Type
==== ====
ETeamDrive crypt
GDrive drive
TeamDrive drive

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q> q

D:\Profile\Synced\Backup\programs\rclone>rclone config --config="…/rclone.conf"
Current remotes:

Name Type
==== ====
ETeamDrive crypt
GDrive drive
TeamDrive drive

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q>


#4

I’m not quite sure what is going on here, but I note you have three . in your config file so .../rclone.conf - I imagine this might be causing the problem. Note that you’ll also want a Windows style path so ..\rclone.conf is probably what you want.


#5

No difference between …\rclone.conf or …/rclone.conf


#6

What do you see in that ..\rclone.conf file? Is it encrypted or not? Try loading it into an editor.

Does rclone have permission to write in ..? Are there any other rclone.conf files in there?

Can you try changing the password with the -vv flag and post the logs?