Configuration for Oracle Cloud Infrastructure Roving Edge Device

What is the problem you are having with rclone?

I tried configuring a REMOTE for OCI roving edge device. This requires directing API calls not to a region, but to a local device. I tried setting "endpoint" to the local device but this didn't have any effect.

In my config:
endpoint = https://Rover3:8019

But endpoint is ignored and API call is directed to the Oracle endpoint for the region associated with the profile.

For this to work, I need to direct the call to a configurable endpoint such as:


instead of

Run the command 'rclone version' and share the full output of the command.

$ rclone --version
rclone v1.65.0

  • os/version: darwin 14.1.1 (64 bit)
  • os/kernel: 23.1.0 (x86_64)
  • os/type: darwin
  • os/arch: amd64
  • go/version: go1.21.4
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Oracle Cloud Infrastructure object storage

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync r3:field-data field-data --interactive

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = oracleobjectstorage
provider = user_principal_auth
namespace = XXX
compartment = XXX
region = us-luke-1
endpoint = https://Rover3:8019
config_profile = RED3

A log from the command that you were trying to run with the -vv flag

Operation Name: ListObjects
Timestamp: 2023-12-08 18:05:23 +0000 GMT
Client Version: Oracle-GoSDK/65.51.0
Request Endpoint: GET

welcome to the forum,

well, you have hardcoded region = us-luke-1 in the config file?
tho, not sure removing that will fix the issue.

I have a region in the config file because, well, rclone config wouldn't let me leave it blank.

I tried removing the "region" line from this profile in rclone.conf and rclone picked up the region from my .oci/config profile. So I commented out region in my .oci/config and rclone reports:

$ rclone sync r3:field-data-collect-to-cloud field-data --interactive
2023/12/08 10:36:50 ERROR : user_principal_auth: failed to create object storage client, can not create client, bad configuration: did not find a proper configuration for region, nor for OCI_REGION env var

rclone really wants a region badly for OCI, but in this case I want to use --endpoint to override any region default endpoint.

the config file is a simple text file, so just edit it.

i see that you are using provider = user_principal_auth and config_profile = RED3
might need to hardcode the config file path using config_file

I did find the rclone.conf and have been trying various changes.

It appears to be picking up changes in the rclone.conf, and also is using .oci/config okay. Not sure what change you are suggesting.

(BTW I have profiles for both RED3 and r3, so while my examples may reference both they are both valid.)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.