Config_token don´t show the http link

What is the problem you are having with rclone?

I am running the rclone in a dedicated server with just SSH acess. So, in the remote config, rclone is not displaying the link to get the config_token. Instead of showing the http link, it's showing the following information:

Option config_token.
For this to work, you will need rclone available on a machine that has
a web browser available.
For more help and alternate methods see: https://rclone.org/remote_setup/
Execute the following on the machine with the web browser (same rclone
version recommended):
        rclone authorize "drive" "xxxxxxxbnRfaWQiOiIzNzE4MTg2MzQ5MTMtYjU2dmx1dDJtb2lia3NodGE3ZDYzbHU2OG5vZDdqazAuYXBwcy5nb29nbGV1c2VyY29udGVudC5jb20iLCJjbGllbxxxxxxxV0IjoiR09DU1BYLV9IVXo4QlgtTTIycFlHVXBWR1NPUmpPRWNXQloiLCJzY29wZSI6ImRyaXZlIiwidGVhbV9kcml2ZSI6IjBBQXNERHZPYWdmMWRVazxxxxxxx"
Then paste the result.
Enter a value.
config_token>

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.1

  • os/version: ubuntu 16.04
  • os/kernel: 4.9.160-armada375 (armv7l)
  • os/type: linux
  • os/arch: arm
  • go/version: go1.17.9
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Shared Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

The rclone config contents with secrets removed.

Edit remote
Option client_id.
Google Application Client Id
Setting your own is recommended.
See https://rclone.org/drive/#making-your-own-client-id for how to create your own.
If you leave this blank, it will use an internal key which is low performance.
Enter a string value. Press Enter for the default (xxxxxxxxxxxx-b56vlut2moibkshta7d63lu68nod7jk0.apps.googleusercontent.com).
client_id> xxxxxxxxxxxx-b56vlut2moibkshta7d63luxynod7jk0.apps.googleusercontent.com
Option client_secret.
OAuth Client Secret.
Leave blank normally.
Enter a string value. Press Enter for the default (GOCSPX-_HUz8BX-M22xxxxxxxSORjOEcWBZ).
client_secret> GOCSPX-_HUz8BX-M22xxxxxxxSORjOEcWBZ
Option scope.
Scope that rclone should use when requesting access from drive.
Choose a number from below, or type in your own string value.
Press Enter for the default (drive).
 1 / Full access all files, excluding Application Data Folder.
   \ (drive)
 2 / Read-only access to file metadata and file contents.
   \ (drive.readonly)
   / Access to files created by rclone only.
 3 | These are visible in the drive website.
   | File authorization is revoked when the user deauthorizes the app.
   \ (drive.file)
   / Allows read and write access to the Application Data folder.
 4 | This is not visible in the drive website.
   \ (drive.appfolder)
   / Allows read-only access to file metadata but
 5 | does not allow any access to read or download file content.
   \ (drive.metadata.readonly)
scope> 1
Option root_folder_id.
ID of the root folder.
Leave blank normally.
Fill in to access "Computers" folders (see docs), or for rclone to use
a non root folder as its starting point.
Enter a value. Press Enter to leave empty.
root_folder_id>
Option service_account_file.
Service Account Credentials JSON file path.
Leave blank normally.
Needed only if you want use SA instead of interactive login.
Leading `~` will be expanded in the file name as will environment variables such as `${RCLONE_CONFIG_DIR}`.
Enter a value. Press Enter to leave empty.
service_account_file>
Edit advanced config?
y) Yes
n) No (default)
y/n>
Already have a token - refresh?
y) Yes (default)
n) No
y/n>
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine

y) Yes (default)
n) No
y/n> n
Option config_token.
For this to work, you will need rclone available on a machine that has
a web browser available.
For more help and alternate methods see: https://rclone.org/remote_setup/
Execute the following on the machine with the web browser (same rclone
version recommended):
        rclone authorize "drive" "xxxxxxxbnRfaWQiOiIzNzE4MTg2MzQ5MTMtYjU2dmx1dDJtb2lia3NodGE3ZDYzbHU2OG5vZDdqazAuYXBwcy5nb29nbGV1c2VyY29udGVudC5jb20iLCJjbGllbxxxxxxxV0IjoiR09DU1BYLV9IVXo4QlgtTTIycFlHVXBWR1NPUmpPRWNXQloiLCJzY29wZSI6ImRyaXZlIiwidGVhbV9kcml2ZSI6IjBBQXNERHZPYWdmMWRVazxxxxxxx"
Then paste the result.
Enter a value.
config_token>

You have to run the rclone authorize command as there is no link anymore.

Just follow on the screen directions.

As I mentioned in the problem, my dedicated does not have a web browser. So I need an http link to copy and paste into the browser outside of the dedicated one.

You need a machine with a browser.
You need rclone binary on that machine.

There is nothing to run on that machine other than exactly what is displayed which is the rclone authorize drive command as shown on the output.

What is the last version of rclone that directly shows the http link to get the config_token?

The old way was deprecated by Google so you’d want to use the current way.

What’s the issue preventing you from just following the current path?

Now I figured out how to get the config_token. But for that, I need to run rclone authorize "drive" "xxxxxxx" with rclone "installed" on my local machine. But it's alright. Thanks.

Yep. I mentioned that a few times.

Happy you got it working.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.