Config seafile with 2fa, "Password can't be blank"

What is the problem you are having with rclone?

trying to config a seafile remote, with 2fa enabled. followed the example from Seafile.
but at the end, instead prompting for 2fa code, rclone keeps printing "Password can't be blank" repeatedly.
tried to copy the log but failed, after choosing "n" for advanced config, rclone immediately starts to quickly print tons of "Password can't be blank" lines, sweeping anything in the screen. sorry but can't get the log.
so frustratedly, decided to use an older version, v1.52.3, and it did the config without problems.

What is your rclone version (output from rclone version)

rclone v1.56.0
- os/version: ubuntu 18.04 (64 bit)
- os/kernel: 5.4.0-42-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.16.5
- go/linking: static
- go/tags: none

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

@creativeprojects - any thoughts?

I'm a bit puzzled by this one, I'll give it a try on a clean machine tomorrow.

Which version of Seafile are you using? I have to admit I haven't upgraded for a while

1 Like

the server is v7.1.5 CE


  • the latest version rclone is fine for connecting and transfering with seafile. currently using it without issue;
  • the latest version rclone has issue when config a seafile remote with 2FA (Password can’t be blank);
  • the v1.52 version is doing well to config seafile;

Right, I found the issue, the defect was introduced in version 1.56

I'm working on a fix :slight_smile:

In the meantime, it is safe to generate a token with a version < 1.56, then use 1.56 with the generated config.

By the way, I forgot to mention it was fixed in version 1.56.1 :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.