Command "rclone config" to set up a new OneDrive not working for region 3 ("Germany")

What is the problem you are having with rclone?

I run rclone config fine (region option "3" (Germany))¹ until it wants to web-authorize.
Browser opens, doesn't open.
nslookup brings 3 addresses in the 51.4.145.x net but Windows tracert says reports: Destination net unreachable

working option 1 (Global) opens, non-working option 3 (Germany) unsuccessfully tries to open

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.0

  • os/version: Microsoft Windows 10 Pro 21H1 (64 bit)
  • os/kernel: 10.0.19043.1288 Build 19043.1288.1288 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rest of the questions doesn't apply at this stage

Actual questions

a) I tried 3 machines, 2 in Germany, 1 in Turkey with same result. Could someone please verify?
b) Any other way to setup a new OneDrive in rclone?

¹ option 1 ("Global") does work in the same setup

during the rclone config command, there should be a weblink, that you can manually paste into a web browser.

If your browser doesn't open automatically go to the following link:

so i would open a bew private window, paste in the weblink and login that way.

Thanks, but

It shows the complete link, but to no avail (as the host is apparently unreachable).

We had another report of this, but I don't know whether it was resolved or not.

Does using the global region work?

Maybe microsoft have changed how this works - any doc research gratefully received :slight_smile:

yes. as reported in the opening post global region does work, it's what I settled for for now:



Have you got any idea whom/where the original docs were from (i.e. where to start looking for the updated docs)?

Glad global works.

Maybe we need to just remove the DE region but it would be nice to have some docs to back that decision up.

The original region support was added in this commit as part of adding a china region.

The original issue

links to this doc

which no longer mentions a DE region.

On this page i found a mention of the DE region being deprecated in 2020

And on this page Azure regions decision guide - Cloud Adoption Framework | Microsoft Learn I found this text

Azure Germany is being deprecated in favor of standard nonsovereign Azure regions in Germany.

So it seems very likely the DE endpoints have been deprecated, though I haven't found the official announcement yet or a date as to when that happened.

Any further ideas? Think it is safe to remove the DE support in rclone?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.