Coming back to rclone after a year, now nothing works


#1

I uploaded several TB to Google drive last year and either I’ve completely forgotten how to use it (possible :slight_smile: ) or something got broken with the configuration. I have the same .rclone.conf on macOS that I used before, but I get errors when I try to enumerate the remote directories. I also tried with the GUI and got similar errors.

$ rclone lsd enc:
2018/08/23 08:54:26 Failed to create file system for "enc:": failed to make remote "gdrive:enc" to wrap: couldn't read info about Drive: Get https://www.googleapis.com/drive/v2/about?alt=json: oauth2: cannot fetch token: 400 Bad Request
Response: {
  "error" : "invalid_grant",
  "error_description" : "Bad Request"
}

and here is my rclone.conf

[gdrive]
type = drive
client_id =
client_secret =
token = {"access_token":"ya29.Gl2rBJJcQVNDSUV4Nasn9BTFJQA2QgBLG9DJmgrAq4_tS2-6LPU82RsGYWRy4V20gAOU1u3-lwo-AJbmqWTCa1QQ_ofIQIKf-WUscSNtoW8AVXREnh6LWtDEBViyL_Q","token_type":"Bearer","refresh_token":"1/6l_LsBc0CM0fI0vUSFUzpj4keRrAUGMV_yY8xhGW_FI","expiry":"2017-08-18T14:53:48.814751422-06:00"}

[enc]
type = crypt
remote = gdrive:enc
filename_encryption = standard
password = obfuscated
password2 = obfuscated

The token expiring in 2017 seems to be a problem, but I am not sure how to refresh the token. I apologize if this is a newbie question, but I’m a little stuck and would definitely appreciate the help :slight_smile:


#2

You should just need to reauthenticate. Do rclone config and select e to edit a remote. Select the remote you want to reauthenticate with. Select no everytime it wants you to edit an existing value. When you are given these three options:

--------------------
y) Yes this is OK
e) Edit this remote
d) Delete this remote

Select y. It will ask you if you want to refresh the access token.

y) Yes this is OK
e) Edit this remote
d) Delete this remote
y/e/d> y
Remote config
Already have a token - refresh?
y) Yes
n) No
y/n> 

Select y and you will be able to reauthenticate to fix your remote.


#3

Yep, that worked. I had only tried to edit the config for the encrypted directory in the past, but editing the gdrive gave me the option of refreshing the token and everything works well now. Thanks!


#4

I’m late to the party, but i appreciate this answer. I had the same issue and this fixed it. Thank you!