Coing CRAZY trying to set up Dropbox on Raspberry Pi!

What is the problem you are having with rclone?

Unable to mount dropbox on raspberry Pi. Followed instructions at exactly but no luck. Dropbox website says rclone is connected but RPi cannot see it or mount it. Not looking for complex settings or configuration I just want to mount, read and write to my Dropbox from my RPi.

What is your rclone version (output from rclone version)

<rclone v1.54.0

  • os/arch: linux/arm
  • go version: go1.15.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Raspberry Pi OS 32 bit

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount /home/pi/dropbox or
rclone mount dropbox OR
rclone ls dropbox OR
many others

The rclone config contents with secrets removed.

$ rclone config
Current remotes:

Name                 Type
====                 ====
rclone config        dropbox

A log from the command with the -vv flag

$ rclone -vv
2021/02/19 15:34:58 DEBUG : rclone: Version "v1.54.0" starting with parameters ["rclone" "-vv"]

For any of the remotes, you want to tag on a ":" at the end so:

rclone ls dropbox:

and that should fix any of your commands :slight_smile:

1 Like

Hi there.
Seems you have created a remote with name "rclone config". Probably not what you intended..? Did you see the example "session" ("This will guide you through an interactive setup process:") at Try to follow that.

Then, you need to add : suffix when referring to the remote name. So if you have a remote called "dropbox" (of type "dropbox", it can be a bit confusing when writing about remotes with same name as the backend/storage-system type) you would have to do:

rclone ls dropbox:
rclone mount dropbox: /home/pi/dropbox


1 Like

Thanks. I successfully changed the name from "Dropbox" to "My Dropbox".
rclone ls "My Dropbox": lists all the directories, subdirectories and filenames which is good. But there are many files taking up lots of space (I have a 2TB dropbox)

When I attempt to mount as follows, the following happens.

~ $: rclone mount "My Dropbox": /home/pi
2021/02/19 18:38:43 Fatal error: Directory is not empty: /home/pi If you want to mount it anyway use: --allow-non-empty option

If I allow-non-empty option will the mounting eat up my drive space on my RPi? Or will "My Dropbox" contents remain in the cloud?


this question gets asked on the forum all the time.

the answer is always the same.
mount to an empty folder and do not use allow-non-empty option

the mount command itself does not use any hard drive space.
if you access a file in the mount, rclone will download it or a chunk of it, depending on what flags are used.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.