Cloning virtual machine to rclone mount point

I am using Koofr storage provider with rclone and want to clone VirtualBox virtual machine to it.

When I tried it for first time it failed and I received this error in rclone log:

2024/04/18 13:38:49 ERROR : Alpha QA Clone/Alpha QA Clone-disk1.vdi: WriteFileHandle: Truncate: Can't change size without --vfs-cache-mode >= writes

So I tried to mount rclone like this:

/usr/bin/rclone mount koofr: /home/pin/koofr --daemon --attr-timeout 0s --dir-cache-time 0s --log-file=/home/pin/rclone.log --log-level INFO --vfs-cache-mode writes --cache-dir /mnt/disk1/cache --vfs-cache-max-size 60G

But because VDI image file is bigger than 60G it seems that cache-max-size is not observed and I run out of disk space resulting in error again.

Any tip what could I try with VBoxManage tool or rclone mount command that would enable me to clone to that cloud storage mount point directly?

I am using rclone 1.67.0 beta

pehaps use rclone copy instead of rclone mount

I don't see how I can use rclone copy and VBoxManage together to clone VM to cloud.

correct, that is a soft-limit, not a hard limit

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.