Cleanup does nothing

What is the problem you are having with rclone?

I was expecting that this will clear my gdrive trash but it does nothing. When I run it, it immediately finished with no output text or whatever and it doesn't cleaned my trash. I also tested if I can access the root of my gdrive, I tried to copy a simple file from my desktop to the root folder and it works.

What is your rclone version (output from rclone version)

rclone v1.51.0

  • os/arch: linux/amd64
  • go version: go1.13.7

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone cleanup gdrive:/

A log from the command with the -vv flag

2020/08/16 16:33:08 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rclone" "cleanup" "gdrive:" "-vv"]
2020/08/16 16:33:08 DEBUG : Using config file from "/home/t2x/.config/rclone/rclone.conf"
2020/08/16 16:33:09 DEBUG : 5 go routines active
2020/08/16 16:33:09 DEBUG : rclone: Version "v1.51.0" finishing with parameters ["rclone" "cleanup" "gdrive:" "-vv"]

Sometimes Drive takes a while to purge trashcan files after the command has been accepted. Do you have a lot of them?

There may be indications of progress from the Google Drive web gui - select My Drive, the i button and activity tab. Alternatively rclone about gdrive: after a time, and you should see the trash volume going down.

I checked now, my trash is now cleaned! I didn't know that the cleanup takes a while. Docs or the terminal print should've said that it takes a while. Anyway, thanks!

1 Like

A log message would be a good idea here. Fancy making an issue on GitHub about that?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.