Can't uninstall Rclone

What is the problem you are having with rclone?

I cannot uninstall Rclone. I don't understand what this means. I managed to mount a drive, so I thought the installation was fine. I don't know what append.

Run the command 'rclone version' and share the full output of the command.

Microsoft Windows [Version 10.0.22621.1413]
(c) Microsoft Corporation. All rights reserved.

C:\Users\mazel>rclone version
rclone v1.62.1

  • os/version: Microsoft Windows 11 Home 22H2 (64 bit)
  • os/kernel: 10.0.22621.1413 Build 22621.1413.1413 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive.
Tried Mega, but that didn't work.
Now both are deleted.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I can't find any command to uninstall. I tried uninstalling from the in the control panel and got this error.

hello and welcome to the forum,

rclone is a portable app, does not require an installer.
so how did you install rclone?

Through Winget.

So add --force as noted in your output to remove it.

the link you posted, is for Chocolatey package manager, not winget

1 Like

The link "Chocolatey" actually takes me to Winget. At least on my computer.

1 Like

ok, winget is a new addition to rclone.

imho, i would not uninstall just yet,
perhaps someone with winget experience can explain that message.
no need to corrupt your system just yet.

1 Like

The thing is, I can't find anything in the commands list related to "uninstall" or "remove" a package. So I don't have any command to add --force to.
The output you saw is from uninstalling here:

Oh, I see. Thanks you.

So it turns out that since it was installed via winget, it also should be uninstalled via winget. Pretty obvious, in hindsight. This removed it:
winget uninstall Rclone.Rclone --force

Ah! Does anyone fancy put that in the install docs?

Not as far as I can see

yeah, i can do that.

i do not understand the need for --force?
if i install rclone, then immediately uninstall rclone, then what was modified to trigger this message?
Unable to remove Portable package as it has been modified

i have never used winget, so just tried it now.
i took a look at the winget log, and there is a problem.

[CLI ] Symlink target does not match ARP Entry. Expected:  Actual: C:\Users\user01\AppData\Local\Microsoft\WinGet\Packages\Rclone.Rclone_Microsoft.Winget.Source_8wekyb3d8bbwe\rclone-v1.62.2-windows-amd64\rclone.exe
[CLI ] Portable file has been modified: C:\Users\user01\AppData\Local\Microsoft\WinGet\Links\rclone.exe

edit: i found this
"For zip + portable packages, if the target executable file is in a subfolder of the zip archive, WinGet will always report the portable package has been modified and thus can't be uninstalled."

I think it is a bug in winget which hopefully will get fixed at some point. There is also Problems with portable applications · Issue #3085 · microsoft/winget-cli · GitHub which is possibly a dupe of the one you posted.

yes, i agree.
so based on that, for now, we need to use --force.

i will do a pull request

1 Like

here is the pull request
update docs: How to uninstall rclone via winget by asdffdsazqqq · Pull Request #6863 · rclone/rclone · GitHub

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.