Can't seem to edit folders/files

What is the problem you are having with rclone?

I just set up RClone for the first time to use with Google Drive and am trying to mount a particular folder to my file system.

What is your rclone version (output from rclone version)

rclone v1.50.0

  • os/arch: linux/amd64
  • go version: go1.13.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Elementary OS 5.0 Juno

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount remote:Library /mnt/gdrive/library

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

2019/11/03 08:52:32 DEBUG : rclone: Version "v1.50.0" starting with parameters ["rclone" "-vv" "mount" "remote:Library" "/mnt/gdrive/library"]
2019/11/03 08:52:32 DEBUG : Using config file from "/home/dualhammers/.rclone.conf"
2019/11/03 08:52:32 Fatal error: Can not open: /mnt/gdrive/library: open /mnt/gdrive/library: no such file or directory

I assume this is user error (I am still very new to Linux). I have tried running it both as sudo and non-sudo and get the same error.

I think the error here is simply that the location
/mnt/gdrive/library
does not currently exist.
I believe FUSE can only mount to an existing location.

try making that folder first - then re-running the same command

In case you are new to Linux, the command to make a directory is
mkdir /mnt/gdrive/library

Please use an empty directory though. mounting to a folder that already has local files in it is a recipe for various trouble (even if technically possible).

Does this mean I need to create a folder for every single folder that I want to pull from my remote before I can pull it down?

I am surprised that RClone can't create sub folders

No, there shouldn't be any need for that - but the parent folder to the mounting point must exist. Perhaps I should have been more spesific. Let me illustrate with an example:
(excuse the windows folder format)

rclone mount remote:: C:\MyGrdive
that will work fine (and the folder MyGdrive does not have to exist beforehand - FUSE will simulate it for the duration of the mount)

rclone mount remote: C:\nonextantfolder\MyGdrive
that's not going to work.

So in your example, if you just make sure to create the "gdrive" folder you should be fine.
Or skip that whole folder and just mount to /mnt/library if you prefer that and really don't want to make any folders. As long as the parent folder to the mounting destination exist you can mount anywhere you want.