Cant see file or folders from host mount on docker container

I mounted a path to my b2 bucket on my host linux server. Folders and files from the remote will show when searched from ls -l on the host but they do not show within the docker container. I can successfully mount a volume between host and docker container and share local files.
My rclone mount config is:
sudo rclone mount --umask=0 b2:remote/path /path/to/host --allow-other --vfs-cache-mode full

Any assistance would be greatly appreciated.

When you posted, there a template that had a bunch of info. That helps us help you as it gives us the critical information needed.

Can you please enter that info.

What is your rclone version (output from rclone version)

rclone v1.52.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 20.04.1 LTS (GNU/Linux 5.4.0-42-generic 64)

Which cloud storage system are you using? (eg Google Drive)

Backblaze b2

The command you were trying to run (eg rclone copy /tmp remote:tmp)

sudo rclone mount --umask=0 b2:remote/path /path/to/host --allow-other --vfs-cache-mode full

The rclone config contents with secrets removed.

[b2]
type = b2
account = removed
key = removed
hard_delete = false

A log from the command with the -vv flag

2020/08/01 16:39:50 DEBUG : rclone: Version "v1.52.2" starting with parameters ["rclone" "mount" "--umask=0" "b2:stonevedenmedia" "/root/media" "--allow-other" "-vv"]
2020/08/01 16:39:50 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2020/08/01 16:39:50 DEBUG : B2 bucket stonevedenmedia: Mounting on "/root/media"
2020/08/01 16:39:50 INFO  : B2 bucket stonevedenmedia: poll-interval is not supported by this remote
2020/08/01 16:39:50 DEBUG : Adding path "vfs/forget" to remote control registry
2020/08/01 16:39:50 DEBUG : Adding path "vfs/refresh" to remote control registry
2020/08/01 16:39:50 DEBUG : Adding path "vfs/poll-interval" to remote control registry
2020/08/01 16:39:50 DEBUG : : Root: 
2020/08/01 16:39:50 DEBUG : : >Root: node=/, err=<nil>
(this is all i get before the terminal goes unresponsive)

I have a feeling that there is a docker flag you need for this to work...

Also check your --allow-other is working - can you list the fuse mount as a different user on the same machine?

Alternatively run your docker as the same user that started the rclone mount.

Note that running fuse mounts as root means no-one can share them I think.