Can't mount ACD (fusermount permission error?)


#1

I’ve set up a remote for unencrypted amazon cloud drive which is working as expected. I tried to mount using:
rclone mount acd: ~/acd &

And I get this error:
2016/12/17 16:43:29 mount helper error: fusermount: failed to open /etc/mtab: Permission denied
2016/12/17 16:43:29 mount helper error: fusermount: failed to access mountpoint /home/USER/acd: Permission denied
2016/12/17 16:43:29 Fatal error: failed to mount FUSE fs: fusermount: exit status 1

I’m on Ubuntu 16.04. Can anyone give me some advice to fix this?


#2

Is your fusermount setuid?

It should look like this

$ ls -l /bin/fusermount
-rwsr-xr-x 1 root root 30800 Jul 12 08:03 /bin/fusermount

To fix it do sudo chmod u+s /bin/fusermount


#3

I checked /bin/fusermount and it is set as you say.


#4

I am also experiencing a similar problem as ToasterFaerie. When trying to mount with rclone, I get:

[1] 14013
2016/12/21 08:37:07 mount helper error: fusermount: failed to open /etc/mtab: Permission denied

However, I noticed that the mount still works despite the error.


#5

Interesting!

So maybe it is the second of the errors that is causing the problem

does that directory /home/USER/acd exist and have the right permissions?

Also are you mounting as a different user to USER?


#6

Yes, /home/USER/acd exists and has the permissions drwxrwxr-x and is owned by the USER. I am trying to mount as that same user.

Based on ezumi’s comment, I tried using the mount anyway and it does not work for me.


#7

Hi ToasterFaerie,

Just wondering, are you using rclone’s built-in crypt for your mount? Your acd: remote points to /home/USER/acd?


#8

I’m not using crypt for this example. I have made an encrypted remote too, and I get the same error.

I am trying to mount my acd drive to the location /home/USER/acd I’ve tried mounting with the error again and I can see the file structure, so it is actually working after all.

I tried copying some files I get errors like this:
USER@server:~$ cp testfile acd/
2016/12/22 15:12:39 testfile: WriteFileHandle.Flush error: Post https://content-na.drive.amazonaws.com/cdproxy/nodes?suppress=deduplication: http: ContentLength=430 with Body length 441
cp: failed to close ‘acd/testfile’: Input/output error

and like this…

USER@server:~$ cp anothertestfile acd/
2016/12/22 15:08:49 anothertestfile : WriteFileHandle.Flush error: HTTP code 429: “429 Too Many Requests”, reponse body: {“logref”:“28383583-c850-11e6-b0f7-f111bfa13631”,“message”:“Rate exceeded”,“code”:""}
cp: failed to close ‘acd/anothertestfile’: Input/output error

Are these typical connection errors? Is it not possible to copy files to the mounted drive this way?

Should I be able to see /home/USER/acd mounted when I run the df command? (I don’t see it.)


#9

Yes.

You can write to the fuse mount, but I’d recommend you use rclone copy as it will do retries and work around connection problems which cp to a mount won’t.


#10

Ok. As it stands now I still get the error:
mount helper error: fusermount: failed to open /etc/mtab: Permission denied

However, I am able to read from the mount after. So far I have not able to write to the mount, but as you suggest I am using rclone with much better results. Thanks.


#11

I think this must be a problem with your installation of fuse, but I can’t figure out exactly what!


#12

Just as a point of interest, I did a fresh install on SOYOUSTART dedicated server about an hour ago… Ubuntu 16.04… fresh install with nothing other than a few utilities to install unzip etc etc and then installed rclone and got the same errors as described in this thread.

I ran a findmnt and can see that it looks like its working… and I can LS into my Cloud Storage like normal… but I get these errors like ToasterFaerie.

Now I have installed my setup on 4 different VPS and multiple times over the past 4 months and never been hit with this error before.

I might wipe this install and install Ubuntu 16.10 and see if that makes a difference…


#13

@Onyx

Few things.

SoYouStart uses a custom kernel for their installs which causes some wonky things.

The fusermount error I’ve gotten when mountin/unmounting with a non-root user. The error can safely be ignored as the folder does unmount as intended.


#14

I am also on a Kimsufi sever running Ubuntu 16.04. Maybe this is an issue shared by OVH servers.


#16

Was a solution ever found? I have a dedicated server at OVH with the same problem.


#17

I still get this error message when mounting, but I have been running rclone with otherwise no problems.


#18

Does /etc/mtab exist? It should be a symlink to /proc/self/mounts
eg

lrwxrwxrwx 1 root root 17 Jul 12  2015 /etc/mtab -> /proc/self/mounts

#19

Yes, I have:

lrwxrwxrwx 1 root root 19 Nov 13 2016 /etc/mtab -> ../proc/self/mounts

And if I open it I can see the rclone mount listed. :confused: