Can't install rclone on raspbian

What is the problem you are having with rclone?

I can't install rclone due to expired certificates. I'm trying to use the -k or --insecure parameters but still not working. this is the message i get " curl: (60) SSL certificate problem: certificate has expired

What is your rclone version (output from rclone version)

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

curl | sudo bash 
curl -k | sudo bash 
curl --insecure | sudo bash 

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

You are probably running an old version and you'd need to update it.

If you can't do that, you can download the version that matches your architecture here:

1 Like

thanks. It could be but its supposed to be the most recent version cause im running the command line suggested in the rclone site. I just downloaded the zip file but to be honest not sure how to install from zip file in raspbian. I'm not an active user of the SO, and only found information on how to install tar files.

the instruction to install from zip are here...
just skip first curl command, as you have already downloaded the zip file

1 Like

This looks like the certificate store for your raspbian is out of date and needs updating.

Something like

apt update
apt install ca-certificates
1 Like

Hi! I experienced the same problem, the solution was to update to the latest volumio firmware. firmwares before the latest one have ca-certificate issues. Ill quote the official announcement below:

" Dear Volumioer,

Currently volumio users are experiencing issues with different streaming services, like Qobuz, Tidal, Webradios and Spotify. This issue is caused by an expired ca-certificate that provides encrypted communication over the internet.

This issue applies to all versions and is addressed in the latest version 2.915 (available as an update).

Please update your device as soon as possible by going to Settings โ†’ System โ†’ System Updates and press Check Updates.

By doing so, everything will be back to normal.

If you are still experiencing issues after the update then please comment in this thread in the community, or contact technical support for myVolumio users at [Contact us ยท Volumio ]

We appologise for any inconvenience"
Hope it helps

1 Like

Thanks everyone for your solutions. I actually ended up installing from the downloaded zip file and it worked. I still tried to update the certificates but the access was denied. Its an old instalation of raspbian, maybe I should do everything again from a clean install. But for now its working. Thanks everyone again

You'll find that rclone may have difficulty with some services for the same reason as most of the cloud services run over https.

1 Like

So now I'm having problems with loading the video on Plex. I tried a picture and a small video and it worked (60mb or something like that) . But with a 800mb it just doesnt load, first i got a message like it was unvailable and now im getting error s1001. I researched and created a cache as i think it might solve or help with the problem, but not quite sure how to mount it. my basic mount its

rclone mount nube: /home/pi/nube --allow-other &

I also read something about being banned. the ban its permanent?

And apoligize me if I should create a new topic for this issue or its ok to ask about it here.


best to start a new topic and answer all the questions.
and post which pi you have, for example i have a pi4 and a pizero

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.