Cant get "suffix = .mp4" to work with "filename_encoding = base32768"

What is the problem you are having with rclone?

am trying to use "filename_encoding = base32768" while also using "suffix = .mp4". am not sure if this is working as design or not but i cant get it to work. i tried with "#filename_encryption = obfuscate" and "filename_encryption = off" and it still doesn't work. basically i want the encryption functionality while adding plain ".mp4" to the filenames.

some references:

Run the command 'rclone version' and share the full output of the command.

rclone v1.64.0

  • os/version: debian 12.2 (64 bit)
  • os/kernel: 6.1.0-13-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.1
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy "remote1_encrypted:"  "remote2_encrypted:" --ignore-existing -q -P --fast-list --transfers 45 --max-backlog 999999 --ignore-checksum --size-only --order-by size,descending --contimeout 30m --timeout 30m

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = xxx
token = XXX

type = crypt
remote = remote1:
filename_encoding = base32768
password = XXX
password2 = XXX
server_side_across_configs = true

type = xxx
token = XXX

type = crypt
remote = remote2:
filename_encoding = base32768
suffix = .mp4
password = XXX
server_side_across_configs = true

A log from the command that you were trying to run with the -vv flag

can provide if needed in the meanwhile here is a screenshot of the result i got so far 


Read docs more carfully - --suffix flag only applies to files' names encryption off

thank you for answering. base on the two link i shared it was implemented for it to work with "filename_encryption = standard" yet it doesn't work not to mention it also doesn't work with "filename_encryption = off"

 encryptedSuffix     = ".bin" // when file name encryption is off we add this suffix to make sure the cloud provider doesn't process the file 

This is from one of your links - it is only for file names' encryption off

Suffix only works when you do not encrypt file names. This is the state of the game today.

I am not sure what would be use of it when files' names are encrypted...

Said that maybe there are special cases you would like it to work differently for a reason - but it means changing this flag behaviour.

i think u are right and idk why i got the idea that this could work with “filename_encoding = base32768” but i really need this. hopefully @ncw can confirm is this merged in v1.63 was implemented to work with “filename_encoding = base32768” and if not then the possibility of adding this feature that am in need off. idk programing for the time being so i can't help on that front. hopefully this doesn't require to much work and can be implemented.

If you think it is important could you create a new thread in "new features" category - so it can be tracked? And explain why it should be done. What is the reasoning behind it etc.

Otherwise it will disappear among all threads here.

i will do that as well create a GH post

1 Like