Can't get clickable token with rclone config

What is the problem you are having with rclone?

I'm trying to set up a remote with Google drive - Drive.
I have correctly configured the Google OAuth client (Ok)

  1. OAuth Client ID (OK)
  2. OAuth Client Passcode (Ok)
  3. Option scope = 1
  4. Option service_account_file = Default
  5. Edit advanced config? = n
    6.Use auto config?
  • Say Y if not sure
  • Say N if you are working on a remote or headless machine
    = n
  1. config_token option.
    For this to work, you will need rclone available on a machine that has
    a web browser available.
    For more help and alternate methods see: Remote Setup
    Execute the following on the machine with the web browser (same rclone
    recommended version):
    rclone authorize "drive" "eyJjbGllbnRfaWQiOiI0NTk1NTY4MjYxMjItb21uY2lvaTJsNnBvMzI0YjN0MWtiMmtpYXVlNWdzbTcuYXBwcy5nb29nbGV1c2VyY29udGVudC5jb20iLCJjbGllbnRfc2VjcmV0IjoiR09DU1BYLVRtYnRhSHd1dGxQejZXYzJ3Z2VnSDJYX0E2TnoiLCJzY29wZSI6ImRyaXZlLmZpbGUifQ"
    Then paste the result.
    Enter a value.
    At step 7: I don't have a clickable link? Example :
    Please go to the following link:
    But !
    rclone authorize "drive" "eyJjbGllbnRfaWQiOiI0NTk1NTY4MjYxMjItb21uY2lvaTJsNnBvMzI0YjN0MWtiMmtpYXVlNWdzbTcuYXBwcy5nb29nbGV1c2VyY29udGVudC5jb20iLCJjbGllbnRfc2VjcmV0IjoiR09DU1BYLVRtYnRhSHd1dGxQejZXYzJ3Z2VnSDJYX0E2TnoiLCJzY29wZSI6ImRyaXZlLmZpbGUifQ"
    And here I am stuck!
    I tried several times with different parameters but I always get the same result?
    Have a nice day and thank you for your help.

Run the command 'rclone version' and share the full output of the command.

Which cloud storage system are you using? (eg Google Drive)

Google Drive

Are you trying to authorize via a headless setup?

You are not supposed to get a clickable link.

You run rclone authorize drive and you get a item you have to copy and paste into the headless side.

It's documented here:

Remote Setup (

Thank you Animosity022 for your answer,
In my config I made a mistake at step:
Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine

y) Yes (default)
n) No
y/n > n
I answered (n) instead of (y)
By answering (y)
Now I can access the link but I still get an error message! I do not know if it's normal ?
[Authorization error] Some parameters are deliberately hidden *********
Error 403: access_denied
The developer has not given you access to this application. It is currently being tested and has not been verified by Google. If you think you should have access, contact the developer (richar***************
Learn more
Request details
The content in this section has been provided by the app developer. Google has not reviewed or validated it.
If you're the app developer, make sure the details of this request follow Google's policies.
access_type: offline
response_type: code
state: ************VKoq3oKYg
If I understood the message correctly, I have to wait for Google's validation of the "OAuth client ID" authorization between two and three weeks?
Thanks for your help Richard :wink:

Are you trying to make a new client ID / secret ? Did you follow something to do that? I'm not sure what problem we are trying to solve.

Making your own client ID has steps here:

Google drive (

Once again a big thank you to you Animosity022,
When re-reading the procedure at the end, I forgot to publish The client_id, so it can't work! :slight_smile:
You found two errors I can't thank you enough :slight_smile:
Thank you for taking your time to help me. It's noob errors I'm sorry!
It's solved thank you!
Have a nice day see you soon Richard :wink: :rofl:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.