Can't follow symlink without -L/--copy-links

What is the problem you are having with rclone?

My source has symlinks. I would like them to be preserved. I am backing up an Aptik backup which is call stored (including the symlink targets) with a nested set of directories (all self contained)

What is your rclone version (output from rclone version)

rclone v1.53.3

  • os/arch: linux/amd64
  • go version: go1.15.5

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux Mint 20

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone --config /home/kenny/.config/rclone/rclone.conf sync Google-MyDrive:/Backups/Aptik /media/kenny/T480-POP-BACKUP/Aptik-Backups

The rclone config contents with secrets removed.

type = onedrive
token = 
drive_id = 
drive_type = personal

type = s3
provider = AWS
env_auth = false
access_key_id = 
secret_access_key = 
region = us-east-1

type = drive
scope = drive
token = ```

#### A log from the command with the `-vv` flag  
<!-- You should use 3 backticks to begin and end your paste to make it readable.  Or use a service such as or   -->

Paste log here

From the docs:

--links   Translate symlinks to/from regular files with a '.rclonelink' extension
1 Like

@jwink3101 does this mean if I sync back in the other direction it will remove the .rclonelink extension and turn it back into what it was at the source?

Yes it does do exactly that :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.