Can't copy some files from webdav server on windows

Hello everybody!
Please help me with the strange html error output.
I've trying to sync folders from windows pc (188:) to linux.
Some files have copied well, but some files have just only created with size of 0 bytes.
This folder can't sync:
shodan@pc:~$ rclone sync 188:/home_media/VIDEO/Russia/2016_F1 /home/shodan/2016_F1

This block repeats too many times.
File list to copy:
shodan@pc:~$ rclone ls 188:/home_media/VIDEO/Russia/2016_F1

36864000 01156.MTS
61046784 01157.MTS
43450368 01158.MTS
29294592 01159.MTS
15335424 01160.MTS
92012544 01161.MTS
280363008 01162.MTS

... and much more files.
What have copied:
shodan@pc:~/2016_F1$ ls -lh

total 3,1G
-rw-rw-r-- 1 shodan shodan 0 Nov 21 18:22 01162.MTS
-rw-rw-r-- 1 shodan shodan 0 Nov 21 18:22 01181.MTS
-rw-rw-r-- 1 shodan shodan 0 Nov 21 18:22 20160430_172436.mp4
-rw-rw-r-- 1 shodan shodan 0 Nov 21 18:22 20160430_173453.mp4
-rw-rw-r-- 1 shodan shodan 0 Nov 21 18:22 20160501_113440.mp4
-rw-rw-r-- 1 shodan shodan 0 Nov 21 18:22 20160501_121529.mp4
-rw-rw-r-- 1 shodan shodan 0 Nov 21 18:22 20160501_123359.mp4
-rw-rw-r-- 1 shodan shodan 0 Nov 21 18:22 20160501_150336.mp4
-rw-rw-r-- 1 shodan shodan 0 Nov 21 18:22 20160501_151140.mp4

shodan@pc:~$ rclone version

rclone v1.49.0-085-g4788545b-beta

  • os/arch: linux/386
  • go version: go1.13

What is the source server?

It might be worth trying a newer rclone - the latest release is v1.50.2

Thanks for the answer.
I use windows 7 x64 IIS Webdav server with basic authentication as the source.
I will try to install rclone v.1.50.2 and I will write a result.

1 Like

I've updated rclone to the last one, but I've got the same error.
Also I've tried to copy the same files using web browser and I've got the error 404 =).
So there is something wrong on the server side. I will check it.
Rclone has have a readable output for that case.

1 Like

Guys, I've found the problem. IIS must have all MIME types configured according to files you want to access to.
If any of a file type is absent so you will have 404 error for these files.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.