Can't Connect to local SSH Server with rclone

I want to create a SSH/SFTP remote that connects from one Mac to another Mac in the same network. The Destination Mac has Remote Access enabled per the and there’s no special configurations I have done to it. In other words, I just went to Settings > Sharing > and ticked the “Remote Login” checkbox to enable it. Assigned myself as an allowed user on that same screen and that’s it.

The remote looks like this:

type = sftp
host =
user = andyibanez
port = 22
pass = 
key_file = 
use_insecure_cipher = false
disable_hashcheck = 

When trying to use it, I get this error:

Failed to create file system for “mbp15:/”: NewFs: couldn’t connect SSH: dial tcp connect: host is down

Worth noting that the host is in fact not down. Currently I can connect to it using other tools such as Cyberduck, or by using the ssh command on the Terminal directly.

I tried setting the password before, but it didn’t work. I was under the impression rclone would prompt for the password the first time.

I’m thinking that it has to do with the fact that I’m using an IP rather than a hostname, but at the same time that shouldn’t make a difference.

You’d need to run rclone config and enter the password or put the password in the file.

You can validate it’s running the SSH server by running:

netstat -an | grep 22 | grep LISTEN

in a command prompt and from the one mac, you can validate you can connect by just doing

telnet 22 or if you don’t have telnet, you can just test with the ssh client and ssh over to validate it’s working.

SSH is working on the destination Mac (tried with both Cyberduck and even just the ssh command through the “sender” Mac).

I also tried running this from the documentation:

eval `ssh-agent -s` && ssh-add -A

But no dice. Tried with both a password and without.

The password parameter is confusing because it’s not clear if it’s the password for the other Mac or something else. The wording (specifically the option to generate a password), is a bit strange and leads me to believe the parameter is not for the user password.

Is there a way to see the underlying command rclone is doing? It would help me see if it’s trying the SSH connection in an unexpected way for me.

Wow it looks like everything has gone bonkers with rclone on my side. EVERY remote is giving that dreadful “host is down” error, despite all them being up! All remote types (including Google Drive, a normal HTTP one) seem to be corrupted.

Figured it all out.

The first time I tried using the SSH remote, Little Snitch created some weird rules and it ended up blocking rclone entirely. I have disabled Little Snitch’s network filtering for now and tomorrow I Will take a better look at what exactly was blocked. Everything is working fine now, including my SSH remote.

Makes sense on what you were seeing. Happy you got it resolved.