Can't configure rclone proxy issue?


I get the following error while auto-configuring: ‘2018/11/21 12:35:56 Failed to configure token: failed to get token: Post proxyconnect tcp: EOF’

I suspect it’s a proxy issue, given that I am going through one, and I suspect it is a trivial question so sorry for that.

Thanks in advance!

How did you set it up to use the proxy?

Like this?

My http_proxy and https_proxy is set for a local proxy server. What should I change? I tried adding address for the token to no_proxy.

What specifically are you typing to set the proxy?

Added to no_proxy

I did not change the http_proxy or https_proxy, because they are set to be used with the local server.

Sorry for nub-like questions once again…

Are you trying to use a proxy or not use a proxy?

Hey, I already have my https, hhtp, and no-proxy variables set up for other programs to use the proxy server. It’s like it says in the FAQ.

How do I configure rclone in a way that it uses my proxy settings?

Otherwise, what else could cause the token error message I mentioned?

What are you specifically typing to set the proxy?

The error message is the proxy connection failed so whatever proxy you have set isn’t correct.

Thank you, I’ll check it tomorrow.
I suspect the issue is that I have it set to http_proxy=‘proxy…:port’ and not http_proxy=‘http://proxy…:port’, but it worked like this for me in the past.

The correct syntax is protocol://hostname:port - eg http://proxyserver:12345. This is because there are also socks5 proxy servers.

However not that you might also need to set https_proxy to the same value. http_proxy is used for http:// traffic and https_proxy is for https:// traffic.

So typically

export http_proxy=http://proxyserver:port
export https_proxy=$http_proxy

will set both. But annoyingly, some programs need HTTP_PROXY and HTTPS_PROXY so I end up also doing

export HTTP_PROXY=$http_proxy
export HTTPS_PROXY=$http_proxy

Just to catch all variations!

1 Like

I had it set on this syntax before, but I only now realized that for some reason HTTP_PROXY and HTTPS_PROXY do not live through restart.

Setting them made the difference, thanks!

1 Like

Would you like to update the faq entry with that - very helpful thank you :slight_smile:


Thank you very much :smile:

Is there a way to get rclone to work with Digest and/or NTLM proxy authentication. Right now it appears rclone assumes proxy authentication is always Basic (set with username:password included) in HTTP_PROXY, HTTPS_PROXY, http_proxy and https_proxy environment variables. Thanks.

rclone only supports BASIC auth at the moment. Can you make a new topic if you have any more questions?