Can't authorize Dropbox with rclone on remote server

What is the problem you are having with rclone?

Long story short, I've had my server purged and been made to start from scratch. So I've had used Dropbox on rclone not too long ago.

Now, I've tried everything: Said both Yes and No to auto config, tried copying an auth code from a local rclone session, but nothing works. I can't get a legitimate connection to my Dropbox account whatsoever. Google and MEGA work fine, so I don't get this.

I would like to resolve this soon, as I only have until October 8th to migrate the rest of my content from MEGA before I am done with that service completely.

What is your rclone version (output from rclone version)

I am on the latest version of rclone as I've just installed it. rclone v1.56.1

Which cloud storage system are you using? (eg Google Drive)

I use Google Drive, MEGA, and Dropbox, but the problem is with Dropbox.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copyto MEGA:Arian Dropbox:Arian -vP

The rclone config contents with secrets removed.

type = dropbox

A log from the command with the -vv flag

I've been spending over 20 minutes trying to figure out how to create a log, but with no avail. If there is anything specific that's needed from my cmd window, just ask me for it. I do apologize for the inconvenience.

Thank you all.

auto config should be the best way.

Make sure your browser is logged into the correct dropbox account before starting (or cut and paste the URL that rclone prints into a new browser session)

Is this a personal or business account?

Are you using --dropbox-impersonate?

What exactly is going wrong? Does rclone config fail? Or does the auth fail when you try to use rclone?

Hi, Nick. Thank you for your reply.

My browser is logged into Dropbox, yes. The problem is, I get a URL like this to copy:

And it takes me virtually nowhere. Then if you pick "no" to auto config, I get this message which frankly makes little sense to me:

For this to work, you will need rclone available on a machine that has
a web browser available.

For more help and alternate methods see: Remote Setup

Execute the following on the machine with the web browser (same rclone
version recommended):

  •    rclone authorize "dropbox"*

Then paste the result.

It is a business account, and I am not using --dropbox-impersonate.

What's going wrong is that I either get the "For this to work" message or I get a link that doesn't do anything. And to answer your other question, both. Trying rclone config from within the remote server fails, but taking an auth code from a local rclone session and attributing it to the remote server like someone recommended didn't work either because then I get this:

2021/09/23 04:16:49 Failed to create file system for destination "Dropbox:Arian": failed to configure dropbox: empty token found - please run "rclone config reconnect Dropbox:"
[apollo ~] rclone config reconnect Dropbox:

I'd really appreciate your help if you can.

It should take you to the dropbox authorization screen which is redirected via rclone.

Are you running a local firewall which is blocking rclone's web server? It runs a web server on port 53682 for the duration of the oauth.

Are you running rclone config on the same machine as the web browser?

I'm guessing not...

So on the server run rclone config - answer no to auto config

Cut and paste the rclone command it prints and run it locally on the machine with the webrowser. You'll need rclone on that machine too. It will eventually print a code which you cut and paste back into the server's rclone config - it will be waiting for you to do that.

Alterntatively run rclone config locally, answer yes to auto config then use the procedure here to copy the config file to the server: Remote Setup

The method of taking a rclone.conf file from a local configuration and putting it on my remote server, so thank you very much for that. That said, I do think things should be more straightforward with those hosts, but I know that's almost completely out of your control, so thank you very much again.

Great. The copying the config file is usually the easiest way to get going on a remote machine - glad it worked for you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.