Can't access OneDrive mounts files

What is the problem you are having with rclone?

I mount OneDrive dirs from windows 10 without any problems. But if I want access them from WSL I can't. I can see a symlink with the name of OneDrive dir Mount but has an error.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10, 64bits

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

PS C:\Users\pepet> rclone mount Descargas: * --vfs-cache-mode full --network-mode
2021/07/26 12:26:29 NOTICE: Assigning drive letter "Z:"
The service rclone has been started.

I tray to access from WSL
chema@PC-Llavaneres:~> rclone.exe lsd z:
          -1 2021-07-16 13:51:07        -1 Descargas
chema@PC-Llavaneres:~> cd z:
-bash: cd: z:: No such file or directory
chema@PC-Llavaneres:~> cd \\z:
-bash: cd: \z:: No such file or directory

The service rclone has been stopped.
PS C:\Users\pepet> rclone mount Descargas: ./Descargas --vfs-cache-mode full
The service rclone has been started.
PS C:\Users\pepet> ls .\Descargas\
    Directorio: C:\Users\pepet\Descargas
Mode                 LastWriteTime         Length Name
----                 -------------         ------ ----
d-----        16/07/2021     13:51                Descargas

chema@PC-Llavaneres:/> rclone.exe lsd /mnt/c/Users/pepet/Descargas
2021/07/26 12:33:35 ERROR : : error listing: directory not found
2021/07/26 12:33:35 Failed to lsd with 2 errors: last error was: directory not found

The rclone config contents with secrets removed.

[Descargas]                                                                                                                                                                                                      type = onedrive                                                                                                                                                                                                  region = global                                                                                                                                                                                                  token = {"access_token":"*************************","expiry":"2021-07-26T13:26:28.6032941+02:00"}                                                                                                                                                                                  drive_id = ****************************                                                                                                                                                                                      drive_type = personal

A log from the command with the -vv flag

chema@PC-Llavaneres:/mnt/c/Users/pepet/.config/rclone> rclone.exe -vv lsd /mnt/c/Users/pepet/Descargas
2021/07/26 12:40:37 DEBUG : rclone: Version "v1.56.0" starting with parameters ["rclone.exe" "-vv" "lsd" "/mnt/c/Users/pepet/Descargas"]
2021/07/26 12:40:37 DEBUG : Creating backend with remote "/mnt/c/Users/pepet/Descargas"
2021/07/26 12:40:37 DEBUG : Using config file from "C:\\Users\\pepet\\.config\\rclone\\rclone.conf"
2021/07/26 12:40:37 DEBUG : fs cache: renaming cache item "/mnt/c/Users/pepet/Descargas" to be canonical "//?/C:/mnt/c/Users/pepet/Descargas"
2021/07/26 12:40:37 ERROR : : error listing: directory not found
2021/07/26 12:40:37 DEBUG : 2 go routines active
2021/07/26 12:40:37 Failed to lsd with 2 errors: last error was: directory not found

Check out:

I'm sorry but I don't see the solution. I change with regedit the option for EnableLinkedConnections and nothings happend

This part:

hello and welcome the forum,

rclone.exe lsd /mnt/c/Users/pepet/Descargas
that creates a symbolic link on windows and wsl cannot see it
that is a known limitation of wsl

as for `rclone mount Descargas: *, wsl is not able to see that.

1 Like

Well, I think I don't explain very well my problem. If mount any OneDrive directory on Windows, I can access there, but if I use WSL or windows subsystem for Linux is where I have problems. I write an examples on my first mail. I'm sorry but I can't see any relation between yours answers and my problem.

OK, thanks for the information

also, in the past, i have tried to use these commands as workarounds, but did not help.
subst x: b:\mount\rclone\remote
mklink /d D:\data\link b:\mount\rclone

what you can do is:

  1. on win, rclone mount remote b:\mount\rclone\remote
  2. on win, net share b:\mount\rclone
  3. on wsl, mount the win share with a command such as
    sudo mount -t cifs -o username=username,password=password // /mnt/rclone
1 Like

If you have WSL2 installed, you can install rclone/mount it like normal Linux.

Thanks, I know, and I installed the first time. But I needed create a fuse module and this WSL seems can't do it. The kind of kernel (Microsoft related kernel) was limited when you want compile kernel's modules. Without fuse module, I can use rclone but not mount anything.
If you know how, I appreciate any help about this.

As I shared above, you need to install WSL2 as it has fuse support.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.