Can't Access Newly Created AppFolderData Remote

I created a new remote hoping to store my backups in the AppFolderData remote, but I’m not having any luck. I keep getting this error:

2018/04/27 21:11:44 ERROR : : error reading destination directory: couldn’t list directory: googleapi: Error 403: The granted scopes do not give access to all of the requested spaces., insufficientScopes

When I configured the Drive, I made sure I chose to use the AppDataFolder. This is what the remote looks like:

type = drive
client_id =
client_secret =
scope = drive.appfolder
root_folder_id =
service_account_file =
token = REDACTED

Do I need to use something else? I was under the impression rclone would create the folder there automatically and i’d have read access, but it doesn’t seem to be the case.

I just tried with my own client secret and ID. No luck.

I just tried running through the process (with the latest beta). Your config is missing this by the look of it:

root_folder_id = appDataFolder
$ rclone config --config /tmp/appfolder
2018/04/28 08:59:33 NOTICE: Config file "/tmp/appfolder" not found - using defaults
No remotes found - make a new one
n) New remote
s) Set configuration password
q) Quit config
n/s/q> n
name> appfolder
Type of storage to configure.
Choose a number from below, or type in your own value
 1 / Alias for a existing remote
   \ "alias"
24 / http Connection
   \ "http"
Storage> drive
Google Application Client Id - leave blank normally.
Google Application Client Secret - leave blank normally.
Scope that rclone should use when requesting access from drive.
Choose a number from below, or type in your own value
 1 / Full access all files, excluding Application Data Folder.
   \ "drive"
 2 / Read-only access to file metadata and file contents.
   \ "drive.readonly"
   / Access to files created by rclone only.
 3 | These are visible in the drive website.
   | File authorization is revoked when the user deauthorizes the app.
   \ "drive.file"
   / Allows read and write access to the Application Data folder.
 4 | This is not visible in the drive website.
   \ "drive.appfolder"
   / Allows read-only access to file metadata but
 5 | does not allow any access to read or download file content.
   \ "drive.metadata.readonly"
scope> 4
ID of the root folder - leave blank normally.  Fill in to access "Computers" folders. (see docs).
Service Account Credentials JSON file path  - leave blank normally.
Needed only if you want use SA instead of interactive login.
Remote config
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine or Y didn't work
y) Yes
n) No
y/n> y
If your browser doesn't open automatically go to the following link:
Log in and authorize rclone for access
Waiting for code...
Got code
Configure this as a team drive?
y) Yes
n) No
y/n> n
type = drive
client_id = 
client_secret = 
scope = drive.appfolder
root_folder_id = appDataFolder
service_account_file = 
token = XXX
y) Yes this is OK
e) Edit this remote
d) Delete this remote
y/e/d> y
Current remotes:

Name                 Type
====                 ====
appfolder            drive

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q> q

$ rclone lsd --config /tmp/appfolder appfolder:
          -1 2018-01-29 13:50:31        -1 sub
$ rclone ls --config /tmp/appfolder appfolder:
     2046 sub/
1 Like

Thanks, that did the trick.

1 Like