Cannot mount Gdrive


I have setup the new mounts for my Gdrive and when I run the command:

rclone lsd gdrive:

I can see my folders from the Gdrive.

I am using this command to mount:

rclone mount -v --buffer-size 32M --read-only --allow-other --gid 33 --umask 0027 --dir-cache-time 300h --poll-interval 5m grive: /mnt/gdrive

But I get this error:

2019/04/21 15:44:13 Failed to create file system for “grive:”: didn’t find section in config file

Any help would be appreciated, thanks.

You have a typo as you are trying to mount ‘grive’ and your config is ‘gdrive’

Just realised and corrected that but now I am getting this error:

2019/04/21 16:01:54 mount helper error: fusermount: user has no write access to mountpoint /mnt/gdrive
2019/04/21 16:01:54 Fatal error: failed to mount FUSE fs: fusermount: exit status 1

And when I run command as sudo, I get this:

2019/04/21 16:03:07 NOTICE: Config file “/root/.config/rclone/rclone.conf” not found - using defaults
2019/04/21 16:03:07 Failed to create file system for “gdrive:”: didn’t find section in config file

It’s telling you that it can’t find your rclone.conf.

The first error means you need to give the user permissions to /mnt/gdrive so the user can mount it.

chown /mnt/gdrive as root.

If you ran the rclone config as a user, you’d want to run the mount as the user. Why are you using sudo?

Thanks, I have used the chown command to change the ownership of /mnt/gdrive to my user so now I have still got this error:

2019/04/21 16:12:19 NOTICE: Config file “/root/.config/rclone/rclone.conf” not found - using defaults
2019/04/21 16:12:19 Failed to create file system for “gdrive:”: didn’t find section in config file

This is my config file:

type = drive
scope = drive
token =
team_drive =

Located in - /home/fayraz/.config/rclone/rclone.conf

Yeah, don’t run it as root. Run it as your user ‘fayraz’ as that’s the user you ran rclone config as.

Why do you want to run it as root or sudo?

Sorry did not answer before I am running as my user and get this message, do I need to move the config file?

I am not trying to run as root or sudo I was just trying to troubleshoot why it is not working.

The message is saying it’s being run as the root user or you have something set to point to the root user such as an environment variable or something maybe.

Couple commands to check:

[felix@gemini ~]$ id
uid=1000(felix) gid=1000(felix) groups=1000(felix)
[felix@gemini ~]$ rclone config file
Configuration file is stored at:

if I flip to root

[root@gemini ~]# rclone config file
Configuration file doesn't exist, but rclone will use this path:

I just tried mounting using the same command again and I think it is now working, the terminal prompt never returned anything and when I check in Plex I can see a gdrive folder with the contents?

Not sure how it is working because for the last 3 days I have been trying stuff myself before posting here?

It could be the chown command I ran for the /mnt/gdrive folder.


Hi Animosity022,

Thanks for your help yesterday everything seems to be working OK but it seems rather slow to me. I have mounted using the command, something I just copied and pasted from someone else:

rclone mount -v --buffer-size 32M --read-only --allow-other --gid 33 --umask 0027 --dir-cache-time 300h --poll-interval 5m grive: /mnt/gdrive

I am using a very primitive server as I will only be using Plex myself, scanning is taking quite a long time and when playing back using Plex it can take an upward of 2 minutes to start.

Is there anything I can change in mount command to streamline the mount?


Did you make your own API key / client ID?

rclone version shows what?

I am using a shared team drive which I have been invited to so don’t think I can create my own keys?

I am using:

rclone v1.47.0

You should ask your admin as using the regular rclone key will not work well.

The client id doesn’t have to be from the account you’re connecting to. Create them with your account.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.